Tools: query list, doesnt work

Hello,

i am using pi.hole on RPi4, 4GB RAM, latest Raspian Buster. I have installed pi-hole via your script.
Version: Pi-hole Version v4.3.2 Web Interface Version v4.3.2 FTL Version v4.3.1

I have insert many blocking lists (~150). Now ~1.6 mio Domains are blocked.
When I try to find a domain in one of these lists, the Tool Query list doesnt work.
There is no reaction of the searching

Debug Token:

ddtest.txt (5 Bytes)

That is not a valid token. Please generate a new debug log, upload it when prompted and post the token here.

thanks,

yes, it was a test if only mods can see attachments.

the debug Log:
upload://7wxG7qiTe2LwAEnPFrmpmKUbXbz.txt) (26.5 KB)

The purpose for posting only the debug token is to maintain your privacy. With the token, only the developers can access your debug log, and it is specially formatted. When you post the log as an attachment, everybody can read it and it may have personal information in it.

the upload directly via
pihole -d
also doesnt work for me.

I think there is no other option to upload something to get a token.

This will temporarily reset the nameserver on the Pi to bypass Pi-Hole DNS.

sudo nano /etc/resolv.conf

edit nameserver 127.0.0.1 to nameserver 9.9.9.9 or your preferred third party DNS service, save and exit

Run pihole -d and upload the debug log

changing the dns in
/etc/resolv.conf
does not solve the upload-prob:

[?] Would you like to upload the log? [y/N] y
    * Using e[32mcurle[0m for transmission.
[e[91m✗e[0m]  e[91mThere was an error uploading your debug log.e[0m
   * Please try again or contact the Pi-hole team for assistance.
   * A local copy of the debug log can be found at: e[96m/var/log/pihole_debug.loge[0m

In the log, I found this error:

e[95m*** [ DIAGNOSING ]:e[0m Dashboard and block page
[e[91m✗e[0m] Block page X-Header: e[91mX-Header does not match or could not be retrieved.e[0m
e[91mHTTP/1.1 200 OK
Set-Cookie: PHPSESSID=8k808cua7gjmrlqerdbc8ek328; path=/
Expires: Thu, 19 Nov 1981 08:52:00 GMT
Cache-Control: no-store, no-cache, must-revalidate
Pragma: no-cache
Content-type: text/html; charset=UTF-8
Date: Wed, 15 Jan 2020 13:27:34 GMT
Server: lighttpd/1.4.54

I think with
upload://7wxG7qiTe2LwAEnPFrmpmKUbXbz.txt
the dev can found the complete log

This is your original problem statement. When you ran this command, was it run from the web Admin GUI > tools > query lists?

Have you tried the command line equivalent of this command:

pihole -q -adlist {insert domain here without brackets}

Lighttpd is showing this error - disk full when trying to write to the log:

-rw-r--r-- 1 www-data www-data 4484 Jan 14 23:53 /var/log/lighttpd/error.log
   ...
   2020-01-14 22:40:30: (mod_accesslog.c.185) writing access log entry failed: /var/log/lighttpd/access.log No space left on device 
   2020-01-14 22:40:31: (mod_accesslog.c.185) writing access log entry failed: /var/log/lighttpd/access.log No space left on device

You have Pi-Hole blocking disabled. Is this intentional?

with pi-user:
for example: pihole -q -adlist teredo
offers the correct lists

–> You have Pi-Hole blocking disabled. Is this intentional?
I think you mean logging, right?

with which user does lighttpd write to /var/log/lighttpd/ ?
with www-data or pihole?
chown for /var/log/lighttpd/ ist www-data:www-data

No, you have blocking disabled in setupVars.conf.

And the problem with logging is not the user, it’s that you are out of space.

i just had a look on the system:

–>
/etc/pihole/setupVars.conf:
BLOCKING_ENABLED=true

–>
/var/log/pihole/
/var/log/lighttpd/
I can create files in that folders as much i want

Remember.
pihole itself does it work.
pihole -q -adlist XXX also works fine

The problems is that the equivalent in webinterface for
pihole -q -adlist
does not work.

And the second problem, when using
pihole -d
and say yes to upload, this upload does not work

I disabled blocking temporarely because i thought this would fix the upload problem. That is why you see disabled in the log.

new log:
upload://radGfiqIPVI1AGTBYjJaoP2zkU8.txt

There is no debug log - nothing uploaded as an attachment. Here is what I see on my screen from your post:

What are the outputs of the following commands from the Pi terminal:

df -h

sudo cat /var/log/lighttpd/error.log

sudo cat /var/log/lighttpd/error.log.1

sudo service lighttpd status

pi@raspi:~ $ df -h
Dateisystem    Größe Benutzt Verf. Verw% Eingehängt auf
/dev/root        29G    9,4G   18G   35% /
devtmpfs        1,8G       0  1,8G    0% /dev
tmpfs           2,0G    632K  2,0G    1% /dev/shm
tmpfs           2,0G    1,1M  2,0G    1% /run
tmpfs           5,0M    4,0K  5,0M    1% /run/lock
tmpfs           2,0G       0  2,0G    0% /sys/fs/cgroup
/dev/mmcblk0p1  253M     53M  200M   21% /boot
tmpfs           391M       0  391M    0% /run/user/109
tmpfs           391M       0  391M    0% /run/user/999
tmpfs           391M    8,0K  391M    1% /run/user/0
2020-01-19 22:02:40: (server.c.1521) server started (lighttpd/1.4.54) 
2020-01-19 22:02:40: (server.c.1550) WARNING: unknown config-key: alias.url (ignored)

at the moment, no error.log.1 file

● lighttpd.service - Lighttpd Daemon
     Loaded: loaded (/lib/systemd/system/lighttpd.service; enabled; vendor preset: enabled)
     Active: active (running) since Sun 2020-01-19 22:02:40 CET; 5min ago
    Process: 1164 ExecStartPre=/usr/sbin/lighttpd -tt -f /etc/lighttpd/lighttpd.conf (code=exited, status=0/SUCCESS)
   Main PID: 1171 (lighttpd)
      Tasks: 6 (limit: 4915)
     Memory: 12.7M
     CGroup: /system.slice/lighttpd.service
             ├─1171 /usr/sbin/lighttpd -D -f /etc/lighttpd/lighttpd.conf
             ├─1178 /usr/bin/php-cgi
             ├─1180 /usr/bin/php-cgi
             ├─1181 /usr/bin/php-cgi
             ├─1182 /usr/bin/php-cgi
             └─1183 /usr/bin/php-cgi

Jan 19 22:03:33 raspi sudo[1271]: pam_unix(sudo:session): session closed for user root
Jan 19 22:04:59 raspi sudo[1398]: www-data : TTY=unknown ; PWD=/var/www/html/admin ; USER=root ; COMMAND=/usr/local/bin/pihole status web
Jan 19 22:04:59 raspi sudo[1398]: pam_unix(sudo:session): session opened for user root by (uid=0)
Jan 19 22:04:59 raspi sudo[1398]: pam_unix(sudo:session): session closed for user root
Jan 19 22:05:04 raspi sudo[1430]: www-data : TTY=unknown ; PWD=/var/www/html/admin ; USER=root ; COMMAND=/usr/local/bin/pihole status web
Jan 19 22:05:04 raspi sudo[1430]: pam_unix(sudo:session): session opened for user root by (uid=0)
Jan 19 22:05:04 raspi sudo[1430]: pam_unix(sudo:session): session closed for user root
Jan 19 22:05:09 raspi sudo[1461]: www-data : TTY=unknown ; PWD=/var/www/html/admin ; USER=root ; COMMAND=/usr/local/bin/pihole status web
Jan 19 22:05:09 raspi sudo[1461]: pam_unix(sudo:session): session opened for user root by (uid=0)
Jan 19 22:05:09 raspi sudo[1461]: pam_unix(sudo:session): session closed for user root

has anybody a suggetion how to solve this?

I just took a second look at your debug log that was sent earlier. You are not running a supported OS for Pi-Hole. Raspbian is only supported through Buster.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.