Timeout accessing raw.githubusercontent.com

System Raspberry Pi 4, 2GB Buster version 10

I am executing sudo python3 whitelist.py and am seeing

This script will download and add domains from the repo to whitelist.

All the domains in this list are safe to add and does not contain any tracking or adserving domains.

[i] Pi-hole path exists

[i] Write access to /etc/pihole verified

[X] URL Error: [Errno 110] Connection timed out whilst fetching https://raw.githubusercontent.com/anudeepND/whitelist/master/domains/whitelist.txt

I select the two suggested blacklist items on install they had the same issue.

There are many posts on this and I have tried most of them. My timezone is correct and my network is as simple as it gets. I have the same issue with blocklists

pi@raspberrypi:~/whitelist/scripts $ pihole -g
  [i] Neutrino emissions detected...
  [✓] Pulling blocklist source list into range

  [✓] Preparing new gravity database
  [i] Target: https://raw.githubusercontent.com/StevenBlack/hosts/master/hosts
  [✗] Status: Connection Refused
  [✗] List download failed: using previously cached list
  [i] Received 59725 domains

  [i] Target: https://mirror1.malwaredomains.com/files/justdomains
  [✗] Status: Connection Refused
  [✗] List download failed: using previously cached list
  [i] Received 26854 domains

  [✓] Storing downloaded domains in new gravity database
  [✓] Building tree
  [✓] Swapping databases
  [i] Number of gravity domains: 86579 (86541 unique domains)
  [i] Number of exact blacklisted domains: 1
  [i] Number of regex blacklist filters: 0
  [i] Number of exact whitelisted domains: 0
  [i] Number of regex whitelist filters: 0
  [✓] Flushing DNS cache
  [✓] Cleaning up stray matter

  [✓] DNS service is running
  [✓] Pi-hole blocking is Enabled

Am I missing something? Thanks

This typically indicates a problem outside of Pi-hole. You are able to resolve the domain name, but the server won't make the connection.

Please upload a debug log and post just the token generated by

pihole -d

allowing to upload when prompted, or do it through the Web interface:

Tools > Generate Debug Log

I can get to nothing including Google. I am not sure what you mean by token because I can't see anything like that in the text.

pihole.txt (21.2 KB)

I attached the command output.

The token would have appeard if you would have answered the question about uploading to tricorder.pihole.com.

I just had a quick look at your debug log and there is one malformated entry on your blacklist

*** [ DIAGNOSING ]: Domainlist (0/1 = exact white-/blacklist, 2/3 = regex white-/blacklist)
   id    type  enabled  group_ids     domain                                                                                                date_added           date_modified        comment                                           
   ----  ----  -------  ------------  ----------------------------------------------------------------------------------------------------  -------------------  -------------------  --------------------------------------------------
   1      1          1  0             -i                                                                                                    2020-11-18 11:58:44  2020-11-18 11:59:30                  

I don't know how you could add it - it fails for me via web interface. Did you add it via directly SQL injection?
Delete that entry and see if it resolves the issue.

I added nothing. I can see the file whitelist.txt and list.0.raw.githubusercontent.com.domains and list.1.mirror1.malwaredomains.com.domains in /etc/pihole where the last two look OK but the first one is empty. I am not sure where the blacklist goes and I also don't know where and how to delete the row you indicated.

BTW, when the log was done it asked whether I wanted to upload and I said yes but it failed.

Try

pihole -b --nuke

That command doesn't work because it needs more information. My problem is simply the network. I cannot get out from the server to anywhere; google, gihhub, etc. I have static IP addresses for etho and wlan0. I can ping it from and to the server but that doesn't prove a lot. SSH is enabled on the pihole server.

What am I missing?

It should have worked - there is only a bug within the command that displays the help text after it finished (fixed already.)
What is the output of

sqlite3 /etc/pihole/gravity.db -header -column "Select * from domainlist;"

I'm not sure as your pihole is able to resolve a query using a public DNS server

[✓] doubleclick.com is 142.250.72.238 via a remote, public DNS server (8.8.8.8)

If it would not be able to contact the outside world it wouldn't return 0.0.0.0 but an empty response (or NXDOMAIN)

Your pihole complains about

192.168.0.222/24 does not match the IP found in /etc/pihole/setupVars.conf

but in fact it matches

*** [ DIAGNOSING ]: Setup variables
    PIHOLE_INTERFACE=eth0
    IPV4_ADDRESS=192.168.0.222

You can try to run pihole -r and choose reconfigure to set it again.

Do you allow outgoing traffic on port 53 to

    PIHOLE_DNS_1=1.1.1.1
    PIHOLE_DNS_2=1.0.0.1

I just went ahead and rebuilt the entire thing one more time and now all is ok. I must have missed or included something that messed it up. Thanks for all the help and patience. :grinning:

It is obvious that I will need help in the coming weeks with networks and making this work so please watch out for me :crazy_face: