Thousands of Total Queries, 0 Blocked

Expected Behaviour:

New installation in a Synology NAS using docker. Asus Router configured to use Pihole as DNS Server.

Actual Behaviour:

I get thousands of queries, but nothing blocked. I got 215,393 domains in blocklist.
If I stop pihole container, all my devices on the network are unable to find any websites.

Debug Token:

https://tricorder.pi-hole.net/5kk43vwe6z

I don't know what I'm doing wrong. I even added some extra lists to my blocklist.
I know queries are going through the pihole, because if I stop the docker container, I get DNS errors on all the devices on my network. I even tried manually black listing some sites, and they still go thought when I try them on any of my computers.

Your debug log shows you've disabled blocking, at least at some time yesterday (only relevant lines shown):

*** [ DIAGNOSING ]: contents of /var/log
-rw-r--r-- 1 root root 47153 Jul 30 18:44 /var/log/pihole-FTL.log
   -----tail of pihole-FTL.log------
  [2020-07-30 18:31:57.616 1351M] Blocking status is disabled

Let's check your current stats:

 echo ">stats >quit" | nc localhost 4711

Where ?
On the WAN or LAN side ?

Also this about Asus routers and DHCP:

Thank you!, I didn't disable blocking, but today I tried disabling and re enabling it and it started working.
Sorry to waste our time, I didn't think of this, because the disable button in the dashboard didn't say that It was disabled.