Teleporter NOT restoring (or backing up?) all relevant data?

Hi,

To start with ... Thanks for this super piece of software. Use it a lot, saves me up to 50% of DNS queries and a lot of unwanted data being transmitted to and from the internet!

Issue:
When I create a backup using the teleporter (under settings), restoring the complete set of data (all options selected!) to a second pihole on different RaspberryPi, works in essence but:
1] it does NOT seem to restore any of the whitelist data.
2] under Group Management -=> Domains, it shows the list misses entries (I presume its the same the full whitelist?)
3] under Settings -=> API/Web Interface, it does NOT restore any of the filled in Top Domains / Top Advertisers nor Top Clients
4] also the Local DNS records are NOT restored.

Restoring the data to a second pihole shows me the following:
Processed adlist (55 entries)
Processed adlist group assignments (55 entries)
Processed blacklist (exact) (34 entries)
Processed blacklist (regex) (9 entries)
Processed client (0 entries)
Processed client group assignments (0 entries)

My view: not all the data is being backed up. Is there a reason for this?
Request would be to enrich the backup :slight_smile:

Regards.

============
Details about my system:
Pi-hole** [v5.1.1]
Web Interface** [v5.1]
FTL** [v5.1]
Raspberry PI 4 backing up to RapsberryPi 3B
Both running: Linux raspberrypi4 5.4.51-v7l+ #1327 SMP Thu Jul 23 11:04:39 BST 2020 armv7l GNU/Linux

What I have changed since installing Pi-hole:
Only tested it since Pihole v5.1; Have no info on older versions.

Have you examined the export file and verified that the relevant lists were exported?

Good one. I just did and indeed the missing data does seem to be in the downloaded backupfile.
When restoring I selected all the tick boxes ("restore all").

Are there any errors after importing in

/var/log/lighttpd/error.log

or

/var/log/pihole-FTL.log

?

Thanks. I checked. Indeed some errors in /var/log/lighttpd/error.log. No errors in /var/log/pihole-FTL.log
See below.

Any suggestions?

Output /var/log/lighttpd/error.log

2020-08-02 11:26:42: (mod_fastcgi.c.421) FastCGI-stderr: PHP Warning: SQLite3::exec(): no such table: blacklist in /var/www/html/admin/scripts/pi-hole/php/teleporter.php on line 90
2020-08-02 11:26:42: (mod_fastcgi.c.421) FastCGI-stderr: PHP Warning: SQLite3::exec(): no such table: regex_blacklist in /var/www/html/admin/scripts/pi-hole/php/teleporter.php on line 90
2020-08-02 11:26:42: (mod_fastcgi.c.421) FastCGI-stderr: PHP Fatal error: Cannot redeclare error() (previously declared in /var/www/html/admin/scripts/pi-hole/php/func.php:126) in /var/www/html/admin/scripts/pi-hole/php/func.php on line 126

Output logged in /var/log/pihole-FTL.log

[2020-08-02 11:26:41.667 13692M] Shutting down...
[2020-08-02 11:26:41.765 13692M] Finished final database update
[2020-08-02 11:26:41.767 13692M] ########## FTL terminated after 5.989596e+04 s! ##########
[2020-08-02 11:26:43.131 25676M] Using log file /var/log/pihole-FTL.log
[2020-08-02 11:26:43.132 25676M] ########## FTL started! ##########
[2020-08-02 11:26:43.132 25676M] FTL branch: master
[2020-08-02 11:26:43.132 25676M] FTL version: v5.1
[2020-08-02 11:26:43.132 25676M] FTL commit: b522646
[2020-08-02 11:26:43.132 25676M] FTL date: 2020-07-15 22:26:33 +0100
[2020-08-02 11:26:43.132 25676M] FTL user: pihole
[2020-08-02 11:26:43.132 25676M] Compiled for armhf (compiled on CI) using arm-linux-gnueabihf-gcc (Debian 6.3.0-18) 6.3.0 20170516
[2020-08-02 11:26:43.132 25676M] Starting config file parsing (/etc/pihole/pihole-FTL.conf)
[2020-08-02 11:26:43.132 25676M] SOCKET_LISTENING: only local
[2020-08-02 11:26:43.132 25676M] AAAA_QUERY_ANALYSIS: Show AAAA queries
[2020-08-02 11:26:43.132 25676M] MAXDBDAYS: max age for stored queries is 365 days
[2020-08-02 11:26:43.132 25676M] RESOLVE_IPV6: Resolve IPv6 addresses
[2020-08-02 11:26:43.132 25676M] RESOLVE_IPV4: Resolve IPv4 addresses
[2020-08-02 11:26:43.132 25676M] DBINTERVAL: saving to DB file every minute
[2020-08-02 11:26:43.132 25676M] DBFILE: Using /etc/pihole/pihole-FTL.db
[2020-08-02 11:26:43.132 25676M] MAXLOGAGE: Importing up to 24.0 hours of log data
[2020-08-02 11:26:43.132 25676M] PRIVACYLEVEL: Set to 0
[2020-08-02 11:26:43.133 25676M] IGNORE_LOCALHOST: Show queries from localhost
[2020-08-02 11:26:43.133 25676M] BLOCKINGMODE: Null IPs for blocked domains
[2020-08-02 11:26:43.133 25676M] ANALYZE_ONLY_A_AND_AAAA: Disabled. Analyzing all queries
[2020-08-02 11:26:43.133 25676M] DBIMPORT: Importing history from database
[2020-08-02 11:26:43.133 25676M] PIDFILE: Using /run/pihole-FTL.pid
[2020-08-02 11:26:43.133 25676M] SOCKETFILE: Using /run/pihole/FTL.sock
[2020-08-02 11:26:43.133 25676M] SETUPVARSFILE: Using /etc/pihole/setupVars.conf
[2020-08-02 11:26:43.133 25676M] MACVENDORDB: Using /etc/pihole/macvendor.db
[2020-08-02 11:26:43.133 25676M] GRAVITYDB: Using /etc/pihole/gravity.db
[2020-08-02 11:26:43.133 25676M] PARSE_ARP_CACHE: Active
[2020-08-02 11:26:43.133 25676M] CNAME_DEEP_INSPECT: Active
[2020-08-02 11:26:43.133 25676M] DELAY_STARTUP: No delay requested.
[2020-08-02 11:26:43.133 25676M] NICE: Set process niceness to -10 (default)
[2020-08-02 11:26:43.133 25676M] BLOCK_ESNI: Enabled, blocking _esni.{blocked domain}
[2020-08-02 11:26:43.133 25676M] NAMES_FROM_NETDB: Enabled, trying to get names from network database
[2020-08-02 11:26:43.133 25676M] Finished config file parsing
[2020-08-02 11:26:43.135 25676M] Database version is 6
[2020-08-02 11:26:43.135 25676M] Database successfully initialized
[2020-08-02 11:26:43.138 25676M] New upstream server: 8.8.8.8 (0/1024)
[2020-08-02 11:26:43.138 25676M] New upstream server: 8.8.4.4 (1/1024)
[2020-08-02 11:26:43.154 25676M] Resizing "/FTL-strings" from 4096 to 8192
[2020-08-02 11:26:43.158 25676M] New upstream server: 208.67.220.220 (2/1024)
[2020-08-02 11:26:43.158 25676M] New upstream server: 208.67.222.222 (3/1024)
[2020-08-02 11:26:43.165 25676M] Resizing "/FTL-strings" from 8192 to 12288
[2020-08-02 11:26:43.181 25676M] Resizing "/FTL-queries" from 229376 to 458752
[2020-08-02 11:26:43.210 25676M] Imported 8163 queries from the long-term database
[2020-08-02 11:26:43.211 25676M] -> Total DNS queries: 8163
[2020-08-02 11:26:43.211 25676M] -> Cached DNS queries: 1610
[2020-08-02 11:26:43.211 25676M] -> Forwarded DNS queries: 2728
[2020-08-02 11:26:43.211 25676M] -> Blocked DNS queries: 3825
[2020-08-02 11:26:43.211 25676M] -> Unknown DNS queries: 0
[2020-08-02 11:26:43.211 25676M] -> Unique domains: 462
[2020-08-02 11:26:43.211 25676M] -> Unique clients: 14
[2020-08-02 11:26:43.211 25676M] -> Known forward destinations: 4
[2020-08-02 11:26:43.211 25676M] Successfully accessed setupVars.conf
[2020-08-02 11:26:43.241 25680M] PID of FTL process: 25680
[2020-08-02 11:26:43.241 25680/T25681] Listening on port 4711 for incoming IPv4 telnet connections
[2020-08-02 11:26:43.242 25680M] Reloading DNS cache
[2020-08-02 11:26:43.242 25680M] Blocking status is enabled
[2020-08-02 11:26:43.242 25680/T25683] Listening on Unix socket
[2020-08-02 11:26:43.276 25680M] INFO: No regex whitelist entries found
[2020-08-02 11:26:43.288 25680M] Compiled 0 whitelist and 9 blacklist regex filters for 14 clients in 15.3 msec

Thought I'd flush the logs and network table through the webinterface (settings menu)
When flushing network table, the web interface shows a red box at the top stating:

Error

There was a problem applying your settings.
Debugging information:
PHP error (2): implode(): Invalid arguments passed in /var/www/html/admin/scripts/pi-hole/php/savesettings.php:741

I'm starting to feel guilty ;-). Did I do sth wrong when installing Pihole? :slight_smile:

Questions remains: How to solve?

The first step would be to run pihole -r and select repair. This is a general repair, but may not fix this specific problem, but it also won't hurt anything.

Thanks. Already tried that (repair option) both from user pi as well as root; no luck.
I get the feeling it has something to do with read/write access as it couldn't write to $output.

Should I try to completely uninstall and then re-install? And if I do, is there anything else I would need to delete/check, which might be left touched after deinstallation?

Known issue, fixed in the next release.

Guess the issue remains than.

pihole -r doesn’t make a difference. Still whitelist not restored and same errors are in log.

I have been running into the exact same issue trying to restore a backup onto a new Pi-hole install (Armbian running on Banana Pi Pro). I even had the same errors in the /var/log/lighttpd/error.log file.

The only way I was able to get a backup from my original Pi-hole (running on Ubuntu server) was to remove the checkmark to restore Local DNS Records. Once that option was disabled, the restore completed successfully.

Thanks for the suggestion, thatISEguy
Tried the same. Doesn't work for me.

Any suggestions from anyone else?

File a bug at github please

Not sure how to do that, but Ill give it a try.

Thanks.

1 Like