Teamviewer keine Verbindung "nicht bereit"

Hey hey,

ich habe hier leider ein Problem mit meiner Pihole Installation auf meinem Linux-Server, wonach leider Teamviewer auf den Rechnern im LAN nicht mehr funktioniert.
Die Query-Logs geben mir leider keinen Aufschluss, woran es hier hapern könnte, weshalb ich mich mit der Bitte um Hilfe hierbei an euch wende.
Zur Struktur (falls hier wichtige Infos fehlen, gebt bitte Bescheid, ich versuche hier nur grob den Aufbau hier darzustellen):
Es handelt sich hier um eine FritzBox als VDSL-Router, hinter der ein Homeserver (HP Microserver) mit einem Debian als Hypervisor für VMs (KVM, Qemu) steht.
Die VMs, darunter die für Pihole, laufen bridged.
Auf den anderen VMs laufen u.A. Dienste wie Nextcloud, ein Mail-Server mit Roundcube, die vom Server-Hostsystem via Apache Virtualhosts verwaltet werden.
Der Pihole DNS-Server ist bei allen VMs/dem Host-System als DNS Server statisch hinterlegt (192.168.178.6) und wird von der Fritzbox als DNS Server den DHCP-Clienten bekannt gegeben.

Nun ist es so, dass seit ich Pihole aufgesetzt habe, leider Teamviewer nicht mehr funktioniert.
Was ich untersucht/festgestellt habe:
Das Auflösen von login.teamviewer.com auf einem Linux-Client funktioniert wohl:

~ % nslookup login.teamviewer.com
Server:		192.168.178.6
Address:	192.168.178.6#53

Non-authoritative answer:
login.teamviewer.com	canonical name = tv-tm-mco.trafficmanager.net.
tv-tm-mco.trafficmanager.net	canonical name = teamviewerconsole-westeurope.cloudapp.net.
Name:	teamviewerconsole-westeurope.cloudapp.net
Address: 40.114.238.193

Ein Ping verläuft jedoch ins Leere:

~ % ping login.teamviewer.com
PING teamviewerconsole-westeurope.cloudapp.net (40.114.238.193) 56(84) bytes of data.
^C
--- teamviewerconsole-westeurope.cloudapp.net ping statistics ---
33 packets transmitted, 0 received, 100% packet loss, time 32420ms

 ~ % ping www.heise.de
PING www.heise.de(www.heise.de (2a02:2e0:3fe:1001:7777:772e:2:85)) 56 data bytes
64 bytes from www.heise.de (2a02:2e0:3fe:1001:7777:772e:2:85): icmp_seq=1 ttl=56 time=20.6 ms
64 bytes from www.heise.de (2a02:2e0:3fe:1001:7777:772e:2:85): icmp_seq=2 ttl=56 time=19.5 ms

Ein Umstellen an meinem Laptop auf den DNS-Server der FritzBox (also Nutzen des Provider-DNS) führt zu einem erfolgreichen Ping auf auf login.teamviewer.com, insofern liegt es nach meinem Verständnis also am Pihole.
Eine debug log habe erzeugt.
(Für mich) paradoxerweise klappt der Aufruf von login.teamviewer.com im Webbrowser und der Redirect auf https://login.teamviewer.com/LogOn erfolgt.
An einem curl-Aufruf auf die Seite konnte ich auch nichts aufschlussreiches erkennen:

curl -v login.teamviewer.com
*   Trying 40.114.238.193:80...
* TCP_NODELAY set
* Connected to login.teamviewer.com (40.114.238.193) port 80 (#0)
> GET / HTTP/1.1
> Host: login.teamviewer.com
> User-Agent: curl/7.66.0
> Accept: */*
> 
* Mark bundle as not supporting multiuse
< HTTP/1.1 301 Moved Permanently
< Content-Type: text/html; charset=UTF-8
< Location: https://login.teamviewer.com/
< X-XSS-Protection: 1; mode=block
< X-Content-Type-Options: nosniff
< Date: Tue, 08 Oct 2019 21:32:53 GMT
< Content-Length: 152
< 
<head><title>Document Moved</title></head>
* Connection #0 to host login.teamviewer.com left intact
<body><h1>Object Moved</h1>This document may be found <a HREF="https://login.teamviewer.com/">here</a></body>% 

Andere DNS-Server (Google/Cloudflare) / Deaktivieren von DNSSEC / Setzen der Einstellung " Listen on all interfaces, permit all origins" brachten leider alle keine spürbare Veränderung.

Hättet ihr bitte eine Idee/Ansatz, wie man dieses Problem lösen könnte?
Ich bin leider wirklich am Ende mit meinem Latein :frowning:
Wahrscheinlich wird das Problem nicht nur Teamviewer betreffen, ist also vermute ich ein eher generelles Problem.

Vielen Dank im Voraus für Antworten!

Viele Grüße
Markus

Bei mir hat TeamViewer kürzlich ohne Probleme mit Pi-hole funktioniert

Ein Ping zu `login.teamviewer.com` läuft auch bei mir auf einen Time-out:
$ ping -c 33 login.teamviewer.com
PING teamviewerconsole-westeurope.cloudapp.net (40.114.238.193) 56(84) bytes of data.

--- teamviewerconsole-westeurope.cloudapp.net ping statistics ---
33 packets transmitted, 0 received, 100% packet loss, time 804ms

Das halte ich für normal, weil Domänen so konfiguriert sein können, dass sie nicht auf ICMP-Echo-Anfragen (ping) antworten.

Gepingt wird ja auch die IP-Adresse, und Pi-hole ist dabei nur bei der anfänglichen Auflösung des Namens in eine IP-Adresse involviert, was auch in Deinem Fall erfolgreich war:

Dass das funktioniert, war auch bereits aufgrund Deines erfolgreichen nslookup für login.teamviewer.com zu erwarten.

Vielleicht blockt Pi-hole im Verlauf der Kommunikation ein paar andere Domänen-Namen, die TeamViewer verwendet.

Das kannst Du relativ einfach prüfen, wenn Du Pi-hole über die Web-Oberfläche bei der TeamViewer-Verbindung kurzzeitig deaktivierst, z.B. mit Disable|For 30 seconds.
Wenn es dann läuft, stehen TeamViewer-Domänen auf einer Deiner Blocklisten.

Um die zu finden, kannst Du Dir die angeforderten Domänen während der TeamViewer-Versuche statt im Query Log etwas ausführlicher unter Tools|Tail pihole.log anschauen.
Dafür sollte aber möglichst wenig sonstiger Verkehr in Deinem Netzwerk unterwegs sein, da das Log sonst schnell sehr groß und unübersichtlich wird.

Die Namensauflösung für den Ping auf `login.teamviewer.com` kann im Log z.B. so aussehen:
<DatumZeit>: query[A] login.teamviewer.com from 127.0.0.1
<DatumZeit>: forwarded login.teamviewer.com to 192.168.1.1
<DatumZeit>: query[AAAA] login.teamviewer.com from 127.0.0.1
<DatumZeit>: forwarded login.teamviewer.com to 192.168.1.1
<DatumZeit>: reply login.teamviewer.com is <CNAME>
<DatumZeit>: reply tv-tm-mco.trafficmanager.net is <CNAME>
<DatumZeit>: reply teamviewerconsole-westeurope.cloudapp.net is 40.114.238.193
<DatumZeit>: reply login.teamviewer.com is <CNAME>
<DatumZeit>: reply tv-tm-mco.trafficmanager.net is <CNAME>
<DatumZeit>: reply teamviewerconsole-westeurope.cloudapp.net is NODATA-IPv6

Ich drück die Daumen für die Suche :wink:

Hallo Bucking_Horn,

lieben Dank für deine rasche Antwort!
Tatsächlich half auch das kurzzeitige Deaktivieren von Pi-hole leider nicht, allerdings hatte ich vorhin einen Verdacht, der sich wohl bewahrheitet:
Innerhalb einer Windows-VM auf meinem Laptop (ich arbeite normal nur mit Arch-Linux) funktioniert Teamviewer.
Insofern handelt es sich hier offensichtlich um ein Problem mit dem Linux-Clienten bzw. im Zusammenspiel Teamviewer - Linux, also nicht mit Pi-Hole.
Dass das mir erst aufgefallen ist, kurz nachdem ich Pi-Hole installiert habe, ist wohl ein dummer Zufall.
Warum Teamviewer jetzt auf einmal zwar nicht mehr funktioniert, kann ich mir derzeit noch nicht erklären, aber damit bin ich schon einmal einen Schritt weiter :slight_smile:

Vielen Dank noch einmal!