Synology RT1900AC DNS management : Too much DNS settings


I’m lot in my DNS settings with my router.

My internet is coming from a 4G modem
The network is managed my my Synology Router

Synology settings
Local Network : (inside the DHCP settings) Primary DNS and Secondary DNS (my Pihole and
Internet > Manually configure DNS server Preferred DNS server and Alternative DNS Server
(my Pihole and

Coming back to my 4G modem, which by the way in a different subnetwork
I have Primary DNS Server
Secondary DNS Server with 1. pihole and second

1.The main issue I have is, I can’t setup a individual DNS for a specific device,
E.g I would like to use a DNS Geo unlocked for my AppleTV, but whatever DNS I add in the device settings is overwritten by my Synology DNS ( I think the one which is registered in Internet, Preference DNS Server)
if I leave this field bank then I have no internet…

  1. for my 4G modem which is in a different sub, should I use external DNS only such or can I still mention my PiHole local server ?

  2. In my route local network settings, is this only for internal DNS (PiHole) or external DNS (


If you set up your DNS this way, some of the traffic won’t go to the Pi-Hole, it will go directly to Cloudflare. The terms “primary” and “secondary” can be misleading; both DNS entries will be used.

Can you make a sketch of your network setup and post it here?


Thank you, I actually though that Primary DNS was always used and secondary always in case of the first one wasn’t responding, kind of fail-over.

Here is the map, my setup is a bit complex


Primary DNS Server PiHole (
Secondary DNS Server

Router :

Synology RT1900 AC
Internet settings :
IP Address
Subnet mask
DNS Server PiHole (
Set as default gateway Enabled
Manually configure DNS Server
Preferred DNS server PiHole (
Alternative DNS Server

Local Network DHCP -
Primary DNS PiHole (
Secondary DNS
Forward known DNS server : Enabled.

PiHole connected on internet (raspberry pi)


Netgear Orbi 3Gbs in bridge mode
PiHole setup on Docker, connected to ethernet from the NAS to the WiFi AP but not in used yet.


@kevincork Don’t use DHCP for those devices. Instead, assign them static IPs and whichever DNS server you’d like.

Also, like @jfb said, don’t use a secondary/alternate DNS server on your router. Otherwise, your ad blocking will only appear to work some of the time. Instead, tell Pi-hole to forward DNS requests to multiple DNS servers, such as and Pi-hole will filter out all of the ad server requests while sending the non-ad requests to Cloudflare’s DNS for normal resolution.