Synology Issue

hello all.. i just installed a Pihole/Docker on synology 718 and for some reason i cant get the gravity to updated..
im sure i missed something .... i just dont know what.
i have tried many things but nothing works.. whatever i could fine online but no luck

Any help is appropriated.

I have tried to reinstall and same thing happens.. everything works but the gravity updated..


token: c92kxfyszm

any ideas??
Everything else works but blocklist source updated,,,,

Please, not every one at once. so many ideas i don't have time to try them all. :sweat_smile:

Unfortunately there is gonna be some hunting on your part as the docker container does not seem to be able to go out. It could be anything from a firewall issue inside synology to not setting up proper IPs when creating the image. If you have the firewall on i would look into that first if everything has been setup properly.

When i SSH into the container I can nslookup url etc. I can web log in. I can manually add domain to block list etc . What port is gravity using to get it's updates... Is it something out of the blue?

What was your setup method? There are many ways a docker image could be installed and this could effect things differently.

Your way.... Lol
Ip range a bit different but everything else the way you have it.
I have Netgear router ds 718+... one dhcp-router
Works for you not me... Heheh

Ok ill have a look at install method. Im wondering if something changed as of lately as some have had issues within the last 2-3weeks.

You did use the pihole/pihole image? I think diginc/pihole still exists on the docker repository and have never tried to install it.

Can you also export the container settings by clicking on the container and going to settings then export and message the file to me. I know that docker version 18.09.0-505 was having issues with variables and would like to make sure they were all passed even though it was supposedly fixed in the newest 18.09.0-506 release.

Also what version of docker are you running on your synology?

Well... seems that i have the newest docker version(18.09.0-506) and i used pihole/pihole -latest version as well.

thx for you interest in this:)

Ok the only thing I notice on your exported setting is that

 "volume_bindings" : [
         "host_volume_file" : "/docker/pihole/etc-pihole",
         "mount_point" : "/etc/pihole",
         "type" : "rw"
         "host_volume_file" : "/docker/pihole/etc-dnsmasq.d",
         "mount_point" : "/etc/dnsmasq.d",
         "type" : "rw"

Should read....

"volume_bindings" : [
         "host_volume_file" : "/docker/pihole/etc/pihole",
         "mount_point" : "/etc/pihole",
         "type" : "rw"
         "host_volume_file" : "/docker/pihole/etc/dnsmasq.d",
         "mount_point" : "/etc/dnsmasq.d",
         "type" : "rw"

Try this:

  1. Verify you have the folders dnsmasq.d & pihole in /docker/pihole/etc.
  2. Delete your pihole docker container. (Leave the the docker networks you created.)
  3. Download the pihole.json file I am going to pm you and load it to your synology.
  4. Import the pihole.json file by going to container>settings>import.

The only changes I made were to make sure that the volume bindings are pointing to a folder as it looks like its trying to point to a file and not a folder.

I will try it.. but why would that matter..?
It is just the physical location which can be anywhere as long as permissions are correct...
Regardless of my logic I will try it later today and let you know.
Thx for you help.

Having it read etc-pihole instead of etc/pihole is different as etc-pihole is specifying a file and etc/pihole is specifying a folder location. I am assuming pihole is trying to save all the block lists to a single file which is confusing it as it wants to put the block lists into a folder that it can read from.

Piholes code downloads every block list to the folder then compares and removes duplicates. Finally assembling a final block list. That way it only has to download a block list when changes have been made to it.

It may be easier if you want to just stop your container and right click on it and edit the mounting points to the dnsmasq.d and pihole folder locations. As I am not home I am not 100% positive you can change mounting points of a container after creating it though.

I will redo it.. I did it 20 times already trying different settings.

I may be looking at this wrong. If you are positive you volume bindings are going to folders and it is showing the .conf files in a folder named etc-dnsmasq.d then volumes may not be your issue. Being that I cant look at the debug logs and am not a linux guru to even understand them this is harder.

You could try to just focus on Pi.hole by:

Making sure your routers DNS is something other then pihole.
Set your synology to use the routers DNS.
Verify that pihole is using one or two of the default dns like &
Verify the router has no types of force redirect of DNS. (I dont have a netgear to know what it is equipped with.)
Then try and update the lists again.

I can retry a fresh install of mine this weekend to see if something may have changed on the synology docker package that is causing any issues.

The other thing to try if you are positive you volume bindings are going to folders is to:

Stop the container.

Clear the container.

Go into the etc-pihole and etc-dnsmasq.d folders and delete everything inside these folders. (previous install issues may exist if you did not delete the contents of these folders when you tried to install pihole multiple times.)

Then restart the container.

:exclamation: Don't delete everything - if you do that, you lose part of your configuration as well, which will make it hard to run Pi-hole.

Pi-hole's core component (piholeFTL based on dsnmasq) is configured via a set of files under /etc/dnsmasq.d/.

Pi-hole's default configuration options as well as blocklists and long-term database are stored under /etc/pihole/.

Let's take a look at what's in this folders first, so we could figure which files can go and which not (if it is a file issue at all).
That way, we could also verify that you indeed exposed the right folders.

EDIT: Sorry for updating this repeatedly after posting - I just wanted to get the Don't delete out as quickly as possible :wink:

P.S.: For an overview where Pi-hole keeps what, refer to What files does Pi-hole use?