Synology DS220+ Docker dnsmasq: cannot access directory /etc/dnsmasq.d: Permission denied

Good evening,

I have a Synology DS220+ and using Pi Hole through Docker.

It has always worked without problems, however, since the last update it no longer works.
As soon as I start the container, it automatically goes out again.
I have not changed anything in the permissions etc. Watchtower has updated automatically.

Log:

[s6-init] making user provided files available at /var/run/s6/etc...exited 0.
[s6-init] ensuring user provided files have correct perms...exited 0.
[fix-attrs.d] applying ownership & permissions fixes...
[fix-attrs.d] 01-resolver-resolv: applying...
[fix-attrs.d] 01-resolver-resolv: exited 1.
[fix-attrs.d] done.
[cont-init.d] executing container initialization scripts...
[cont-init.d] 20-start.sh: executing...
::: Starting docker specific checks & setup for docker pihole/pihole
Assigning random password: 8jaWXs7Q
[i] Installing configs from /etc/.pihole...
[i] Existing dnsmasq.conf found... it is not a Pi-hole file, leaving alone!
[i] Installing /etc/dnsmasq.d/01-pihole.conf...
[✓] Installed /etc/dnsmasq.d/01-pihole.conf
[i] Installing /etc/.pihole/advanced/06-rfc6761.conf...
[✓] Installed /etc/dnsmasq.d/06-rfc6761.conf
Existing DNS servers detected in setupVars.conf. Leaving them alone
::: Pre existing WEBPASSWORD found
DNSMasq binding to default interface: eth0
Added ENV to php:

		"PIHOLE_DOCKER_TAG" => "2022.01",
		"PHP_ERROR_LOG" => "/var/log/lighttpd/error.log",
		"ServerIP" => "0.0.0.0",
		"CORS_HOSTS" => "",
		"VIRTUAL_HOST" => "0.0.0.0",

Using IPv4 and IPv6
::: Preexisting ad list /etc/pihole/adlists.list detected ((exiting setup_blocklists early))
https://raw.githubusercontent.com/StevenBlack/hosts/master/hosts
dnsmasq: cannot access directory /etc/dnsmasq.d: Permission denied
::: Testing pihole-FTL DNS: [cont-init.d] 20-start.sh: exited 1.
[cont-finish.d] executing container finish scripts...
[cont-finish.d] done.
[s6-finish] waiting for services.
[s6-finish] sending all processes the TERM signal.
[s6-finish] sending all processes the KILL signal and exiting.

I have stumbled upon the same problem after upgrading to latest image, running on synology DS218+ with docker.

I tried to comment out the volumes section of the docker compose file, and that made pihole to start, but obviously all the custom configs were lost. I did check the owner of /etc/dnsmasq.d and that was the root user.

This is the permission for the etc-dnsmasq.d folder on the host (777 and owned by root):

drwxrwxrwx+ 1 root root     58 Jan 14 13:16 etc-dnsmasq.d

I wonder if its related to this change Update embedded dnsmasq by DL6ER · Pull Request #1273 · pi-hole/FTL · GitHub

I reverted to using the 2012.12.1 image version for now.