Synology Docker error "unable to resolve host Pi-Hole" and "unable to send audit message: Unknown error -1"

Hi Guys,
Wondering if anyone could shed some light on 2 errors I'm getting in my Pi-Hole log?

sudo: unable to resolve host Pi-Hole
sudo: unable to send audit message: Unknown error -1

I'm using the official docker container, running on my Synology DS415+. I have all the environment variables set correctly. Pi-hole itself is running perfectly! I just don't understand the error or how to fix it if anyone can help!

Screenshots below


1 Like

Welcome to the Pi-hole community, iceddonut. :slight_smile:

Not sure if this is a Pi-hole issue.
Those above screenshots of yours are not showing Pi-hole's UI, and neither is the log produced by Pi-hole.

In addition, it seems that your are not running the Pi-hole docker image directly, but rather through some kind of process wrapper (presumably, s6 overlay?), as standard Docker Pi-hole wouldn't know or need many of the environment variables shown.

Is it normal for Synology Docker installations to wrap Docker images like that, or is that your own customisation?

The errors you show maybe linked to an older issue, with some leads to the kernel Synology was running on at that time and to the Linux Pluggable Authentication Modules missing some compile-time options, see GitHub for complete coverage.

These have been addressed at the time then, but it's not impossible that they have been reintroduced by some recent changes in Synology or by that process wrapper you are using.

The second screnshot looks fairly normal for configuration, s6 is integrated into official docker-pi-hole as it is the gold standard for multi-process docker images @Bucking_Horn

As for the sudo error, seems sudo command (used within pi-hole's internals) is choking on your container's hostname (inherited from the name you gave it). A simple fix maybe renaming the container a real hostname like our built-in 'pi.hole' hostname - or you could add 'pi-hole' hostname as a custom host into pihole's dnsmasq.d folder with a file like:



with whatever IP address you want instead of