Synology Docker DHCP not working

I setup Pi-hole one week ago on my DS218+ in a docker container in host based on the instructions here: How to Install Pi-Hole on Your Synology NAS – Marius Hosting and it all worked fine!

Since then I setup a Virtual Machine and I've not be able to get DHCP working again. I've since removed the virtual machine and tried to set everything back to how it was, but I just can't get it working.

I can setup the docker container fine and I can access the web ui. If I point a device's DNS to the pi-hole/NAS IP it works correctly, I just can't get it to broadcast DHCP. If I run ipconfig /renew a device will time out.

I feel as though it's going to be a simple setting somewhere that I've missed. I've disabled Open vSwitch which was enabled by the VM, and ensured I'm back on eth0 and the firewall is off. Also in the container log I see Stopping pihole-FTL Starting pihole-FTL (no-daemon) as root sporadically but a few times per hour, I'm not sure if this is related?

I've read a lot and tried a lot ,but I'm far from knowledgeable on any of this! I see a lot of posts about creating a bridge or macvlan etc. but like I say it all worked perfectly 1 week ago prior to the VM on the same setup :confused:

Any help is much appreciated :slightly_smiling_face:


Welcome to the Pi-hole community, Shalayer. :slight_smile:

I dare say that running a plain Docker Pi-hole is not the same setup as stacking that same container into a VM, and on Synology on top of that, making it indeed a special environment. I feel you're kinda doubling the network separation/integration efforts (container to host VM, host VM to host OS).

You may want to take (another) look at the Docker DHCP section in our docs for hints.

However, I fear that this won't exactly address your issue, and I certainly lack expertise and experience to be of help for you chosen stack.

If the guides don't provide any actionable hints either, I'll move this post to our Community Help category (or you may do this yourself) - maybe some user with relevant experiences will chime in.

Thanks for your reply.

I have now removed all of the VM environment (I believe) although I feel that it is a hangover of that which is preventing DHCP from working.

I have looked through the article you have linked to, and it is currently setup as host. I have it all working to a degree, but I have to manually set each devices DNS to point to the NAS IP, and would prefer to simply use the DHCP capabilities.

If you wouldn't mind moving it, it would be appreciated :slight_smile:

I just noticed you already attached your post to Synology category - that's even better, as it's more specific than our more generic Community Help. :wink:

Synology does some weird things when doing complex things.

I would shut off open vswitch if not needed and delete the container. Reboot the synology and reinstall the container.

Ive managed to confuse the ip/network rules multiple times on my synology when doing things that messes with the eth0/eth1 cards/ports. If you have the firewall enable that is another layer that messes up also when installing/deleting programs. A restart usually fixes weird issues if you know something should work but doesnt.