Status Unknown issue

I have a problem with pihole status bar.
I just install pihole in my pogoplug E02.
When I install pihole everything work fine except status unknown issue.
I tried to click the enable button, and the status looks like changed unknown to active.
But it will be changing after I click any of the main navigation.
Also when I click Disable, and check pihole status.
Pihole still running, it is not disable by web interface.
It only can be disable by terminal.

스크린샷 2021-04-09 오후 5.31.29

Please help me to fix it.
I already reinstall the pihole, but still have same issue.

Expected Behaviour:
Status must be active

Actual Behaviour:
Status unknown

Debug Token:

Your log shows multiple reports of:

Executing sudo pihole status web failed.

The PogoPlug isn't a supported platform, did you compile the pihole-FTL binary yourself?

I did compile the pihole-ftl at the first installation. But I didnt install the pihole-FTL at the second installation. However, it still not working an status bar.

Unrelated to the problem, but I recommend you look closely at the output of pihole -g

You have at least one bad URL - this one is not a blocklist and will not import any domains into Pi-hole:


sudo pihole status web

and show the output.

How did you install Pi-hole?

After run that command, I got 1
I just follow instruction of website.
After install the pihole there is running pihole-FTL already.

I just erase it.
Thank you for tell me.

Please post the exact output, screenshot if you can.

Which website, what exactly did you do/type?

Was pihole-FTL previously compiled and copied in before you installed?

Most Pogo devices use a chroot jail and running Pi-hole on them is an advanced skill. It's not supported by Pi-hole or the developers.

This is result of the command.
스크린샷 2021-04-10 오후 1.09.45

This is what I use for installing the pihole in the pogo.

I was installed this pihole-FTL at the first install the pihole

My precondistion is ...
Debian Bustger(OS)
5.11.4-kirkwood-tld-1(Linux Kernel)
swap enabled(512MB)

That's the output of the command when run as root. Pi-hole runs with a non-root user and I seem to remember that changing the user and calling systemctl or service inside the chroot jail that you have to create to get Debian running on a Pogo is not compatible.

I still don't quite understand what you did to install Pi-hole. Did you compile and copy the binary and then run some other command? Or did you run some other command (curl?) first and then compile the binary?

You need to be very specific with the exact commands and steps you used since this really isn't a supported platform for Pi-hole.

Oh! Yes, I'm already installed curl for pihole.
I also hack the pogo and it doesn't have original ui any more.
I will try to installing the pihole with non-root user.

Thank you for helping me.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.