Something's not right

Hi everyone, new poster here.

I had a pihole set up a few years ago while living alone and was very happy with it. Now trying to set it up again and I am doing something wrong - I don't notice a difference at ALL in my devices. Well, sometimes a Youtube video will not continue to load after I hit 'Skip Ad.' That's all. I remembered pihole being an obvious and positive change, so the problem must be something I did.

Am I checking too many DNS lists?

Thank you for any pointers!

Debug Token:

https://tricorder.pi-hole.net/kltzdecfro

No, this is perfectly fine. I have seen a lot more on other users. As long as it does not block stuff you don't want to see blocked, I wouldn't worry about this.

How does your Network Table (Tools) look like? Did you configure your router/DHCP server to announce the Pi-hole as DNS server?

A few notes from your debug log (and looking at your dashboard snap):

(1) The snippet of the pihole.log in your debug log shows queries only from localhost (expected - this is the hourly pulse to resolve local IP names) and client 10.0.0.79. If there are other active clients, they don't appear to be using Pi-hole.

(2) You are subscribing to a block list that is in a format incompatible with Pi-hole (and you are using the list Github page, not the raw list, but that's not the issue here). This will cause false positives. You should remove this list entirely.

https://github.com/easylist/easylist/blob/19161392aa7acf191830f9ec29a29c536067151a/easylist/easylist_adservers.txt

(3) This list is discontinued and no longer available:

https://zeustracker.abuse.ch/byebye.php?download=domainblocklist

(4) This list also appears to not be available:

https://hosts-file.net/ad_servers.txt

Thank you for your replies! I have deleted those old ad lists and left the DNS servers checked on.

My router is from Xfinity and I don't think it lets me change the DNS forwarding. Here is a pic of the settings.

Yeah, others faced this as well



You could try to disable the DHCP server in the Xfinity router and enable pihole's DHCP server. If you can't disable it completely, limit the DHCP scope to 1 address and make a reservation for the pihole device and enable pihole's DHCP in addition.

This is a good solution.

This is the XFINITY network. Can you also provide screenshots of the local IP and Wi-Fi settings?

yubiuser's advice is sound for most situations where a router wouldn't allow configuring DNS at all, i.e. neither upstream (WAN/Internet) nor local (LAN/DHCP) DNS settings.
I just add that you should make sure DHCP ranges do not overlap when multiple DHCP servers are active on the same network.

There may be additional trouble, though:
Following yubiuser's links to the Xfinity forums, it would seem that if you'd use certain ISP provided Xfinity devices, those would even block or redirect port 53, so you are bound to DNS servers as supplied by your router.

While your devices can be configured to use Pi-hole for DNS, Pi-hole itself may not be able to forward DNS requests to the DNS servers of your choice.
DNS won't resolve at all when blocked, or go to other DNS servers if redirected by your Xfinity.

You should be able to diagnose this by running the following command from two clients on your network,a cable and a wifi connected each:

nslookup flurry.com 80.241.218.68

That command should return 0.0.0.0.
If it times out, this would indicate your router blocks public DNS.
If it returns an actual IP, your router redirects DNS requests.

If your router interferes with DNS; you could still point Pi-hole to use your router as its only upstream DNS server, but would have to stick with your ISP's set of DNS servers.

You may be able to mitigate this by using a DoH proxy. I'd better mention we receive occasional reports that DoH using cloudflared seems unreliable at times.