[SOLVED] Web interface frozen

Please follow the below template, it will help us to help you!

If you are Experiencing issues with a Pi-hole install that has non-standard elements (e.g you are using nginx instead of lighttpd, or there is some other aspect of your install that is customised) - please use the Community Help category.

Expected Behaviour:

The web interface should work as it did before. Running on a Zotac AD-12 with 4GB ram and 750GB HD. OS is Debian Buster.

Actual Behaviour:

Interface frozen.

One time, it was able to partially load and there were a lot of allowed queries to scamcoin.ru. My guess is that the web interface is overloaded by all the queries. Is there some way to do some sort of partial reset?

Debug Token:

https://tricorder.pi-hole.net/mr45zy1x2s

After waiting long enough, it does load:

I looked at the logs and I can see scamcoin.ru showing up frequently. Is the client information also there? I was unable to find it. It would be nice to identify the offending device.

Your debug log shows you are processing DNS requests from public clients, e.g.:

*** [ DIAGNOSING ]: contents of /var/log
-rw-r--r-- 1 pihole pihole 70102 Jun  7 13:06 /var/log/pihole-FTL.log
   -----head of pihole-FTL.log------
   [2021-06-07 00:01:07.591 17449/T17455] WARNING: Hostname of client 24.136.12.161 too long
*** [ DIAGNOSING ]: Pi-hole log
-rw-r--r-- 1 pihole pihole 121751059 Jun  7 13:10 /var/log/pihole.log
   -----head of pihole.log------
   Jun  7 00:00:20 dnsmasq[17449]: query[ANY] scamcoin.ru from 94.158.100.200

This means you are running an open resolver, which poses a potential threat for all Internet users, e.g. by serving as a multiplier in a DNS Amplification attack.

Please take down your Pi-hole instance or take measures to make it inaccessible from the Internet like disallowing inbound port 53 traffic on your router/gateway for a home network or applying proper firewalling for a cloud-based installation.

The Pi-hole team strongly discourages Pi-hole’s usage as an open resolver , and we won't provide support in that case.

Thank you! I've turned off the port forward from my AP. I was simply following (a clearly very bad suggestion) from https://bacnh.com/how-to-setup-pi-hole-with-openwrt/.

Yes, this is a very bad advice. If you want to use Pi-hole from outside of your home, use a VPN, e.g.

https://docs.pi-hole.net/guides/vpn/wireguard/overview/