[Solved/Resolved] CloudFlare Upstream DNS Missing


#1

Expected Behaviour:

I should be able to select CloudFlare DNS as an upstream DNS server within the PiHole web interface.

Actual Behaviour:

I cannot seem to select CloudFlare DNS as an option within PiHole. I’m running the latest version of PiHole and I’m not sure why it’s not appearing. Using an original Raspberry Pi model B rev 2 with the latest, updated version of Raspbian available. (See neofetch below)

  Pi-hole version is v3.3.1 (Latest: v3.3.1)
  AdminLTE version is v3.3 (Latest: v3.3)
  FTL version is v3.0 (Latest: v3.0)
[sudo] password for snuggle: 
  [i] Checking for updates...
  [i] Pi-hole Core:     up to date
  [i] FTL:              up to date
  [i] Web Interface:    up to date

  [✓] Everything is up to date!

Screenshot of issue:

Debug Token:

gdzterlcsm


#2

That feature is not included in your version of Pi-Hole, but as you have done, any DNS server can be listed in the custom area.

The beta of FTLDNS has it and I believe I read that it will be included in the V4 release.

Pi-hole version is v3.3-181-ga7e7680 (Latest: v3.3.1)
AdminLTE version is v3.2.1-195-g4355bde2 (Latest: v3.3)
FTL version is vDev-5ecab0a (Latest: v3.0)

The beta FTLDNS page is here: Help Us Beta Test FTLDNS


#3

Ah, interesting! I was just confused because I saw this merge request from back in April and I’ve also seen other people’s screenshots with a CloudFlare option. https://github.com/pi-hole/pi-hole/pull/2075

The Wiki also shows CloudFlare, so I thought I was doing something wrong. :blush:


#4

I’ve upgraded to the Beta/Development branch, since I’m happy with testing new features and reporting any bugs or issues I find. Thank you so much for the help, @jfb. :hugs:

I will edit the title of this thread with a [Solved] tag. c: