[SOLVED] Pi-hole not working, no interface, no command, Pi now unable to resolve DNS

#1

I bought a new RPi 3+ starter kit today with an SD that came preinstalled with Raspbian. Started it up and it booted straight up, all good. Ran sudo apt-get update and sudo apt-get dist-upgrade to get all packages up to date, then ran the Pihole installation seemingly without a problem. Through the update and install process I was getting “locale errors” like this:

perl: warning: Falling back to the standard locale (“C”).
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory

So I ran the fix here: https://unix.stackexchange.com/questions/110757/locale-not-found-setting-locale-failed-what-should-i-do

The locale errors seemed to be warnings only so I didn’t think they would have been a problem. I then continued - I gave the Pi a static IP (.254) and set it as the DNS server in the router

Expected Behaviour:

Expected it to just start working as it’s supposed to

Actual Behaviour:

  • Can’t access admin panel (connection refused)
  • Running pihole returns “bash: pihole: command not found”
  • Pi now can’t access the internet, DNS won’t resolve
  • Devices using the Pi as a DNS can’t resolve sites
  • Connecting to ExpressVPN on PC results in websites working as it forces use of its own DNS (an issue I can fix, but won’t until the Pi works)
  • Unable to re-run installation (or ANY installations) as domains can’t be resolved
  • Pihole does not show up in the list of installed packages
  • Attempted to run install command with pi-hole.net IP address instead of hostname, security certificate does not match. Attempted with http:// instead and got a DNS resolution error.

Debug Token:

Unable to run pihole -d

0 Likes

#2

Recommendation: format the SD card and do a fresh install of Raspbian from the Pi website. Then you know it’s a good install. Get your locale, time zone, languages set for your location. Assign a static/reserved IP from the router.

Then re-install Pi-Hole on that fresh install.

1 Like

#3

The purchase probably cam with a Noob image.
Correcting this failed install is wasting time. Agree with jfb: that is much faster.

1 Like

#4

Thanks for the quick replies. I downloaded the Raspbian image and used Etcher to install to the SD card, then put it in the Pi.

I set locale on install, and IP address is already assigned by MAC address in the router.

Installed Pihole and I can run the pihole command now, but I still get no DNS lookup.

During installation I got the following lines:

Downloading and installing FTL
Error: unable to get latest release location from GitHub
FTL Engine not installed

No other errors during installation.

Any ideas?

0 Likes

#5

What locale do you have set?

1 Like

#6

Australia, en_AU.UTF-8

0 Likes

#8

Found this: Issue with FTL Engine not installed

resolv.conf has no IP addresses, only three lines of comments

0 Likes

#9

Two lines of comments are normal. What is the third?

Here is what is usually seen:

cat /etc/resolv.conf
# Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
#     DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN
nameserver 127.0.0.1
1 Like

#10

I found this: FTL engine not installed latest everything SOLVED

This solution worked and the repair installer did all sorts of cool stuff. I can ping google now.

Do I need to change the resolv.conf file again as it’s got Google’s DNS server in there?

EDIT: Never mind, re-running the installer has changed the resolv.conf to exactly what you pasted.

0 Likes

#11

Never mind, the installer has changed the resolv.conf to exactly what you pasted.

0 Likes

#12

Excellent. Pi-Hole working as expected now?

1 Like

#13

Yep. ExpressVPN app still pushes the PC to their DNS server but there should be an easy fix for that, if not I’ve got a new router arriving in a few days and I’ll be able to set up network-level VPN so the app will go once that arrives.

Thanks for the help :slight_smile:

0 Likes

closed #14

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

0 Likes