[SOLVED] Local DNS not working for itself but every other host

I have pi-hole currently running on my Raspberry Pi 4 B. The problem I'm facing is that I have a few Local DNS records saved [using the Web GUI], and every single DNS query results in correct IP address. But querying it using ping sentinel.local (sentinel.local is what I have set for the Raspberry Pi) doesn't work. at. all.

[ everything below this line is about the Pi on which I have pi-hole running ]
Pi-hole version is v5.3.1 (Latest: v5.3.1)
AdminLTE version is v5.5 (Latest: v5.5)
FTL version is v5.8.1 (Latest: v5.8.1)


cat /etc/hosts localhost sentinel.localdomain sentinel

# The following lines are desirable for IPv6 capable hosts
::1 ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
ff02::3 ip6-allhosts
cat /etc/hostname
cat /etc/pihole/custom.list chief.local ringmaster.local flameboi.local sentinel.local backup.local tv.local 0.vm 1.vm 2.vm 3.vm 4.vm 5.vm 6.vm 7.vm 8.vm 9.vm x.vm

[ everything from this line below is run on a client using (IP address of the Raspberry Pi with pi-hole) as it's DNS ]

nslookup works...

nslookup sentinel.local

Non-authoritative answer:
Name:   sentinel.local

dig works too...

dig sentinel.local

; <<>> DiG 9.16.1-Ubuntu <<>> sentinel.local
;; global options: +cmd
;; Got answer:
;; WARNING: .local is reserved for Multicast DNS
;; You are currently testing what happens when an mDNS query is leaked to DNS
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 55299
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1

; EDNS: version: 0, flags:; udp: 65494
;sentinel.local.                        IN      A

sentinel.local.         2       IN      A

;; Query time: 0 msec
;; WHEN: Sun Jun 13 23:43:02 IST 2021
;; MSG SIZE  rcvd: 59

but ping doesn't

ping sentinel.local
ping: sentinel.local: Name or service not known

[ log entries of running pihole -t while I run ping and nslookup on a client ]

log entry when I run nslookup

23:40:17: query[A] sentinel.local from
23:40:17: /etc/pihole/custom.list sentinel.local is
23:40:17: query[AAAA] sentinel.local from
23:40:17: cached sentinel.local is NODATA-IPv6

log entry when I run ping

23:41:25: query[SOA] local from
23:41:25: forwarded local to

log entry when I run dig

23:43:02: query[A] sentinel.local from
23:43:02: /etc/pihole/custom.list sentinel.local is

Why does nslookup and dig work but ping doesn't? I did make a Git issue previously, but it turned out it wasn't a pi-hole problem. Don't want to harass the dev with my own issue [again].

I did have network wide, but do not use it currently

pihole -d

1.) Don't use .local as your DNS domain name.
.local is reserved for usage by the mDNS protocol.

2.) Note that laptop and laptop.lan are two distinct domains
Each domain would need its own DNS record (or records) to be resolved successfully.

3.) For automatic consideration of your local domain name, see e.g. [SOLVED] How can I get the local domain name auto suffixed to hostnames in DHCP?

.lan works flawlessly! Thank you!

On a side note (if you could help), every single device which my router shows on it's "Network Map" is now named "SENTINEL". Any way to prevent this?

Edit: fixed and crossed out

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.