SOLVED - Activating Pi Hole Stops Internet Access


#1

Please follow the below template, it will help us to help you!

Expected Behaviour:

Pi hole should be acting as DNS server

Actual Behaviour:

Pinging Google from client laptop results in “Ping request could not find…”. Connecting to web admin on Pi Hole works just fine though. I have tried the Pi Hole IP as my router DNS server and have now just limited it to changing the DNS setting on the laptop as my Internet access kept stopping throughout the house.
To set Pi Hole up, I used the following instructions : https://opensource.com/article/18/2/block-ads-raspberry-pi

Debug Token:

N/A


#2

How are you setting Pi-hole as your DNS server?


#3

Hi
Thank you for a very swift reply !
I have made note of the IP address of the Pi Hole Pi (Ethernet connected) and have put it into the “Primary DNS” section of my router TP LINK Admin Tool on the DHCP page
This seems to be how they suggested doing it in the article I linked.
When my house Internet kept stopping as a result then I have been setting it on the client laptop in the Ethernet connection properties.
I’ll take a look at the link you sent as I am only just starting out on this and need to learn as much as possible
Thanks again
Ben


#4

As far as I can see, the only DNS set in my router settings is the Pi Hole.
In the laptop network adaptor properties, I have definitely only set up one DNS and that is the Pi Hole
Totally bemused by this


#5

I just ran pihole -d and uploaded the log
Token : 2s9c5xbvfh


#6
[✗] No IPv4 address(es) found on the wlan0 interface.

You won’t be able to respond to queries or get out to the Internet without an IP address.


#7

OK - I feel dumb now ! I really should have known that.
Sorry for the wasted time and many thanks for the response
Cheers,
Ben


#8

@jacob.salmela
Hang on - I am using ethernet on this pi for its Internet access - the wlan0 adaptor should just be for things attaching to it wirelessly
So - the question still remains - how is this not working ?


#9

Solved by installing PiHole via DietPi rather than the standard install


#10

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.