So Long Pihole

Youve been great until last week, then you stopped blocking ads and now, after updating, flushing, restarting everything you are blocking 0% of ads.
So i guess you cant keep up. Time to accept the wave of advertising and re-deploy the pi.

There must be a reason for it not to work.

If you don't see any ads being blocked, it might be due to a few reasons (if everything is working properly and Pi-hole has no errors).

Maybe the queries are not running through the Pi-hole DNS or maybe no lists are loaded ...

thanks, but nothing changed, until I tried to update. It had simply stopped blocking ads and everything i browsed was loaded with ads again.
real pity, but now ive updated it there is 0 activity. pity as it has been excellent.

There are some basic check you can perform to see if it works.

Is the DNS service running, are the adlists concatenated? Does it block locally on the pi ?

I had to manually update the dns and reconnect the API but all now says its running, including the DNS.

Not to sure what this means.

What's the output of sudo systemctl status dnsmasq and sudo systemctl status pihole-FTL.
Also what are the last few lines of /etc/pihole/gravity.list
if you run a nslookup on on your pi, what's the output ?

Send us your debug token and we can take a look.

✓] Your debug token is: yaec3g8xee

Ahh yes, you're on Raspbian Jessie with dnsmasq v2.72, which is unfortunately not supported.

You have a few options on things you can do:

1 Like

so I need to update from Jessie and start again?
got no issues with that.... Just cant do it now. Forgot i hadnt updated the OS for a looooong while.

Yep, you can

  • update to stretch
  • update dnsmasq
  • downgrade Pi-hole
  • beta test FTLDNS

awesome. project for the weekend... thanks.
Much appreciated.


This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.