SmartTV's traffic not tracked

I am running Pi-hole as a docker image on my DS720+. It works well so far. All traffic is tracked (dekstop, laptop, smartphone, tablet, Kindle) except the SmartTV's and the Sky Receiver's traffic.

Pi-hole ist set as local DNS server in my Fritzbox. All devices are in the same network but Pi-hole does not log any traffic from the SmartTV or the Sky receiver.

Any ideas?

SmartTV usually have hardcoded DNS, so are capable to bypass PiHole. You could try to redirect queries to port 53 (DNS) to your PiHole, consult Fritzbox manual on how to do this, should be under NAT rule, if that is possible. Also try in your TV settings, you might be able to change the DNS there without the nat rule. If I recall correctly my tv has DNS settings under the advanced section.
Sky Receiver might be the same problem, I don't have one so I can't be certain.

Sometimes. From user reports, most models respect the network DNS settings.

Thanks for your answers.
In both devices I set the DNS server seperately. Now, everything is working well.