Setup for Pi-Hole with Comcast EA6300 router

I know this is an old thread, but have something very related.

I am running pihole on a raspberry PI, and am using an EA6300 router.

I am using the pihole DHCP on the pi as well. I have turned off DHCP on the EA6300. When DHCP is turned off, there is no means to manually set the DNS on the EA6300 ( that I have found)

I have run with IPV6 turned off and on on the pihole DHCP page.

I am at the point where my phones don’t have the ads blocked consistently. On the PC, I tried turning off IPV6, and it starting blocking ads. When I turn IPV6 back on it again blocks.

I believe that my EA6300 still uses the ISP (Comcast) DNS servers on IPV6, but turns off its DNS for IPV4 traffic, and the pihole is used instead.

Any ideas, besides get a better router? I probably will, but not for a little while, and was hoping there was some other solution that I hadn’t thought of.

TIA for any help
Ken

I did find the solution to the problem was just to turn off IPV6 on the router. You can’t do it on the Android interface, but you can on the browser interface. I was also worried that Comcast would have a problem with that, but it didn’t seem to cause a problem. I suppose they won’t be able to remote IPV4 support for a few years still.

Ken