Setting up the rasberry pi hole

Hello, so I ran into issues.
WiFi network, cable modem to airport express, then to WiFi extender, the WiFi extender has Ethernet.
What I want to do is connect it to the WiFi extender only, is that possible? So the airport express doesn’t have add blocking capable.
I was having trouble with use if the dns settings so if you guys have a good updated link it would be great

If the Pi-Hole is connected on your network and the DHCP server provides the Pi-Hole IP as a DNS Server, all the clients on the network will use that DNS Server.

To set it up as you want you would need to either set up two networks (one on Pi-Hole and one not), or manually assign client DNS (or put the Pi-Hole on the entire network and manually assign selected clients a different DNS Server).

From your description of your network equipment, if the WiFi extender does not have the option of functioning as a router, manual DNS may be your best option with your current setup.

If you use Pi-Hole as the DHCP server, you can use dnsmasq configuration files to allow selected clients to bypass Pi-Hole and use a different DNS Server. This might be the best solution for your setup, as not all clients allow manual DNS configuration.

So, I tried setting it up for the second time, and changed the dns server through my iPhone because it says in the terminal after finishing

Pi hole dns but it had no internet connection

The web server is up and says I have one client but it still doesn’t work through my extender

Both my airport express and extender have the same dns but it is the same as the one in terminal except it has 2 extra letters after it, should I restart it from scratch and manually put in the dns of the extender when it asks for static ip? If I cant do it with the extender I don’t want PiHole


Update: the PiHole rasberry pi itself connected from Ethernet in the extender is ad blocking but not my device :slight_smile:

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.