Setting up Pi-Hole on Asus router


#1

Recently installed the Pi-Hole to block ads. And set the RPI as the DNS server under LAN in my Asus Router.

Expected Behaviour:

The pi-hole should block ads and everything else on my network should work as normal.

Actual Behaviour:

The Pi-Hole works properly but when I set the LAN DNS to the IP address of my RPi I cannot access my router anymore, it just says the webpage can’t be reached. When I check the DNS settings on my Mac it has the IP of RPI as the first then the default gateway as second. If I set the DNS address in my mac to gateway the RPi doesn’t block the ads anymore but I can access the router.

I can’t figure out where it goes wrong or why I cannot access my routers config when it blocks the ads.

Debug Token:

Debug token: dl0krs7oo0


#3

Your debug log shows no problems with the Pi-Hole, so this is a router issue.

There are typically some DNS settings in the WAN interface section. For example, from the manual for an ASUS AC68R router (might not be your model), there is a WAN option to connect to DNS server automatically. This should be deselected, as your DNS server is on your LAN.

Also on the WAN, there is an option for Dynamic DNS - this should be disabled.

Also look for other options such as DNS pre-binding (disable that).

A better option might be to use the Pi-Hole as the DHCP server. When the clients get their lease from the Pi-Hole, they will be assigned the Pi-Hole as their DNS server. There are other advantages to using Pi-Hole as DHCP as discussed here:


#4

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.