Setting up DHCP leases for static IPs

I have an Orbi router which I use to set up various static IPs for devices on my local network. It has an address reservation table looking something like this:

IP Address Device Name MAC Address
192.168.1.56 HUE-BRIDGE 01:17:66:70:GE:99
192.168.1.18 ROKU-STICK F6:3A:6B:A3:73:G1

I’ve now set up Pi-hole as my DNS and DHCP server. It looks like some of these mappings have been carried across to Pi-hole’s “Currently active DHCP leases” table, but have been assigned different IPs based on the range. I also see the “Static DHCP leases configuration” table below seems to be separate and empty.

After Pi-hole setup these local devices with their static IPs are no longer accessible on my network. What should I be doing here to fix these devices, keeping the original IP address set on them if possible?

  • Should I be removing these address reservations in Orbi and use only Pi-hole’s “Static DHCP leases configuration” table for this instead?
  • Should I change the IP range in the DHCP settings to exclude, or include these previously set up devices? Devices don’t seem to get reassigned IPs after I change this range.

Any insight on what I should be doing here to fix my static IPs is appreciated!

Make sure you are only running one DHCP server. Pi-hole has no knowledge of the router’s DHCP reservations, so it will assign new ones. Usually you need to restart the device or its networking to have it renew its DHCP lease (get new DHCP info).

@Mcat12 thanks for your reply. My understanding is I need one DHCP reservation on the router for the Pi (192.168.1.2) to prevent this IP from changing.

What I’ve ended up doing here (based on this comment) is keeping the router’s DHCP server enabled, but to a range of just one address 192.168.1.2. This same address is set up in the router as an address reservation.

screenshot

The router’s DNS server is also set to 192.168.1.2:

screenshot

As for Pi-hole, I’ve set the available address range outside of this to prevent any clashing:

screenshot

All other static IP address reservations I’ve set up within Pi-hole:

Does this sound like an appropriate setup to you?

You do not need to run DHCP on the router if you are running it on Pi-hole.

@Mcat12 but don’t I need a fixed IP for the Pi itself that’s running Pi-hole?

Are you suggesting I set this up as a DHCP lease within Pi-hole? Disabling the router’s DHCP server (which is only using one address like I say) makes my devices unavailable on the network.

You do not need a DHCP lease, as Pi-hole is already set up with a static address. A static address is different than a static lease.

I see, thank you @Mcat12. I have now disabled DHCP on the router.

Just as a final clarification (sorry!) although DHCP is disabled, the address reservation on the router setting the IP for the Pi as 192.196.1.2 should remain?

As DHCP is disabled, the address reservation is also disabled.

Fair enough, but then how do I set the IP address of the Pi to 192.168.1.2? This is outside the range in the Pi-hole settings, so it can’t be set there?

Slightly off topic, but I’m currently running Pi-hole as a Home Assistant addon. After running well for a day or so I come home to the internet connection being down (Orbi shows purple light ring). Resetting the router to factory defaults and re-setting up Pi-hole gets me going again but only until it happens again. The most recent time this happened the Pi simply won’t show up on my network after power cycles - I assume my SD card is blown.

Pi-hole seems important enough to run on a dedicated Pi, but in the meantime this behaviour is disconcerting.

For the first, see /etc/network/interfaces for static IP addressing. If it’s a Raspberry Pi and Raspbian then you’ll have to read the instructions in that file. Normally we set the IP as static with our installation script.

As for running as an addon, that’s not a supported running configuration that we are able to assist with. You’ll have to ask the person that wrote it for support, as they modify our work.

Thank you for the replies, that has cleared some things up for me.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.