Seems to work, but it isn't

Please follow the below template, it will help us to help you!

Expected Behaviour:

block www.google.com

Actual Behaviour:

doesn't block

Ok, so I set my pfsense router's name server to my pihole ip (192.168.1.133) and my chromebook detects this ip as the ip for the name server, so that does seem correct. In pihole I tried adding www.google.com to the blacklist to test if it's working, but google still loads. I see some things blocking though (from the ip of the chromebook), so it seems to be working, but the test fails.

Debug Token:

https://tricorder.pi-hole.net/XHjFSj5G/

Your debug log says that your Pi-hole is at 192.168.96.4. Try that.

Besides the wrong IP, there is another issue:

This won't happen.
You added a regex whitelist to allow google.com. The regex is (\.|^)google\.com$

1 Like

Additionally, whitelist entries override all blocking. So, when you whitelisted the entire google domain and subdomains, none of them will ever be blocked.

The order of precedence is:

  1. Exact Whitelist
  2. Regex Whitelist
  3. Exact Blacklist
  4. Blocklist domains (AKA gravity)
  5. Regex Blacklist

If a domain is found anywhere from top to bottom, FTL skips the rest of the tests.

Tried to change the IP, then I suddenly have no internet access. Also tried a website wich is certainly not in the allow list (my own site www.vandingelen.be), and that didn't work either.