Says it's blocking but I am still seeing youtube ads


I had this configured and worked out of the box. I set it up, on my raspberry pi zero w, set cloudflare as my dns, then updated my router to use the raspberry pi w zero ip as it's dns and it worked great.

Now for some reason it has stopped working.

I reset everything hoping it work, and reinstalle raspberry os lite and pi hole and still shows that it's blocking but ads and youtube ads are still coming through. For the moment it did work, I saw no ads or youtube ads.

I don't think pihole can block youtube ads reliably but normal banner ads should be blocked. your web UI is showing that it has some queries blocked maybe the ads you're seeing are not in the blocklist. try to figure those out (using the query log) and add them to the blocklist

For hours last night all the youtube ads on my iPhone had disappeared. I remember going through a lot of videos all at once and even seeing those yellow dashes to indicate in the video that a ad was going to be served, and no ads were served during countless videos. Now it's back... really strange.

Also how come when I take a look at clients it shows just my routers ip and not individual devices ip's that are being blocked? For example it just shows one conglomerated client and all the queries passing through

Most likely because you configured your router to adverties itself as DNS server via DHCP and set Pi-hole as upstream server for your router. So your DNS queries take the following way

Client -> Router -> Pi-hole

That makes a lot of sense, I've been messing with the settings and playing around with PiHole and if I manually enter the DNS in any device (my smart phone, tv, iPad), I then can see it as it's own individual client, and not as a conglomerated single source.

Which solves that issue.

But I'm still perplexed, for a solid 3-4 hours, my iPhone did not have YouTube ads, and I even tested it by hammering the videos non-stop and even when I passed the tick mark (ad indicator) on the progress bar of the video, no ads came up.

Can someone explain this?

Is it a good idea to turn off DHCP to enable individual client devices to show up?

If this is the setting that enables you to see the client IP's you desire, yes.

Is that a bad idea, I read that disbaling DHCP allows ads to sneak through?

That's not how DHCP works. What DHCP does is assign IP addresses to clients on your network requesting IP addresses. If you don't have DHCP on your network, then you'll have to manually assign every client an IP address. If you want to see your clients appear in Pihole as hostnames, you could disable DHCP on your router and enable it on Pihole, just don't have two DHCP servers on at once.

Strange, but I still think it is coincidence. With Pi-hole it is technical not possible to block YT ads without blocking the video content. Both, video and ads, are served from the same domains. If you block one you also block the other. Trying to block certain YT domains might seem to work for a little while but soon or later it will fail.

1 Like

Thank you for the clarification on DHCP, I appreciate that.

I guess it's a coincidence, but rather strange and perplexing. Well my PiHole is running great, I see individual clients and everything is being blocked, I appreciate all the feed back and my questions being answered by this community. :smiling_face_with_three_hearts:

1 Like

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.