Running, enabled, but not blocking anything?

I recently set up a Pi-Hole for my home network. It's set up as DHCP server for the router at home, so all devices should be covered by the Pi-Hole.

Expected Behaviour:

Network overview - Number of queries should be greater than 0.

Trying nslookup on a blacklisted site (flurry.com) should return 0.0.0.0

Actual Behaviour:

It is not zero only for one device, all other devices are showing 0 queries. The "Uses pi hole" checkmark is marked in all devices in the network, but they are also colored red as they have never queried the PiHole.

nslookup on blacklisted site returns the actual site (I can access it on my browser).

Debug Token:

https://tricorder.pi-hole.net/av1a0hftze

That's an indication for that one device bypassing Pi-hole somehow, presumably by means of an alternative DNS server.

Please post the complete nslookup output for that device when it returns a non-blocked result.

From a client that you believe should be connected to the Pi-Hole for DNS, from the command prompt or terminal on that client (and not via ssh or Putty to the Pi), what is the output of

nslookup pi.hole

Well, I must have misconfigured my system somehow. For the sake of clarity: I just configured my computer to directly connect to the PiHole, and now it works. Before, the nslookup of pi.hole returned "not found" and of a blocked site would return the ip of the site.

Now it's working on my computer.

I lost internet connection on my computer for some reason at some point (I had stopped tinkering with my IP hours before it stopped working). Misconfigured IP adress apparently.

After "fixing" that (using the gateway and DNS of the pihole, and some random IP), it seems to be working as expected - now flurry returns 0.0.0.0 and I can access pi.hole - but only on this computer.

I thought I had set up network wide access, but I guess it's not working. At least I know the system is working now.

Right now on my router I have:

LAN Setup: DHCP disabled, and the PiHole running as DHCP. IGMP snooping disabled.

DNS Server: Static DNS, Primary: PiHole IP. Secondary: 0.0.0.0

On the PiHole itself I have DHCP enabled.

I thought this should be enough for it to work. Any idea what I might be missing?

Have you restarted the router and renewed the DHCP leases on all connected clients?

Ive just restarted the router and tried to renew the DHCP lease on one of my computers. So far I lost connectivity but can't renew the lease ("Cant contact DHCP server" while trying to renew).

I was hoping this could all be done on the router. Will I have to configure the devices one by one? Or will the DHCP lease renew after some time?

Edit: Manually set an IP, DNS and gateway for computer 2. Running on PiHole now.

Edit 2: DHCP leases expired on other devices shortly after (I guess this is why I lost conectivity a bit earlier), and all were unable to re-connect to the network. Were connected, but with no internet access. Had to manually set IP, gateway and DNS on all devices. All working OK now tho.