Router is answering DNS queries instead of selected DNS provider

I have an asus router, that looks like it is answering some of the dns quires instead of google, which I have selected as the dns provider.

I am using a dynamic dns address to find my home network, so I had to give the router a wan dns server to communicate with the ddns provider. When I set the pi-Hole as my routers wan dns I had millions of quires in 30 minutes from a tivo on my network. So I set the wan dns to default and the dhcp dns to the pi-Hole. I don’t think this matters because when I don’t give the router a dns server the behavior is the same, but I thought I should mention it just in case.

Expected Behaviour:

Only have queries answered by cache,google,or blocklist

Actual Behaviour:

router.asus.com is answering dns quires even when I have added it to block list

Debug Token:

https://tricorder.pi-hole.net/lwgp7fe7m8

_

Looks like your clients are not using the Pi-hole IP as their DNS server.

You can do any of the following:

  1. Setup the DNS manually on the clients to the IP of your Pi-hole (192.168.1.132)
  2. If your router lets you set-up DHCP related parameters, set the Pi-hole IP as your LAN DNS.
  3. Setup the same Pi-hole IP in your router as your WAN DNS.
    Also keep in mind this:
  1. Disable the router’s DHCP and use Pi-hole as your DHCP server.
    This is by far the easiest and cleanest method (I run it like this with over 60 clients).

When I setup the Pi-hole as my wan dns as well as lan dns I get millions of dns queries in a few hours, and the Pi-hole crashes.

Your wpad requests (Web Proxy Auto-Discovery Protocol) are usually from (very) chatty Windows based computers.

You might want to research on how to mitigate that on your side of the network.

Can you isolate the machine(s) that are requesting those ?

I think it could be any service that causes the millions of requests, yesterday it was my tivo that caused it. It is as if it creates an endless loop. There is just something that doesn’t work when I set my WAN DNS, and LAN DNS to the Pi-Hole.

Have you considered having Pi-hole as your DHCP server and test that option ?

I am sure using it as my DHCP server would work, I was just hopping to get some experience with it first before jumping in all the way. I just reset the logs and tried again. and after a few minutes I had this.

Untitled5

If you click on that reverse DNS lookup, you will see who requested it.

There are routers out there that don’t play nicely with Pi-hole or any other “not configured within the router DNS” for that matter , due to (understandable) manufacturer security related concerns.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.