Router clients bypassing Pi-Hole DNS


#1

I installed pi hole on my raspberry pi, pointed my router to use it as a DNS server, even disabled DHCP on my router and activated it on pi hole

Expected Behaviour:

All clients in my network should get filtered traffic

Actual Behaviour:

Traffic doesn’t get filtered. On my Mac using the router’s address 192.168.2.1 as DNS server the traffic doesn’t get filtered. Also the pi-hole admin console doesn’t show filtered queries.
When on my Mac I input the pi hole’s IP as DNS server, the traffic gets filtered and the pi-hole admin console shows filtered queries.

Debug Token:

t2qh7zeu4r


Can't get hostnames to resolve with Conditional Forwarding
#2

This normally indicates a router problem. Depending on the model of router, there are a number of ways the router can provide an alternate DNS path other than the Pi-Hole.

Look through all the menus on the router and look for other DNS settings (WAN, LAN, family-filtering, DNS pre-binding, DNS caching, dynamic DNS, IPV6). You may have to solve this through trial and error. Sometimes a setting is buried in a gray-out menu, and when you select the menu and make it active you find an underlying option that is causing the problems.

A second potential problem is DNS caching on clients. This does not appear to be the case on the Mac, since when it goes directly to Pi-Hole for DNS it works. But, Windows PC’s can hang onto DNS settings unless you flush the DNS cache.


#4

Thank you for your reply! I figured that I only set the DNS server in the LAN settings of my router but there was also a DNS server to be input in the WAN settings…
Now everything works as expected