Resolving IPv6 ULA names

Expected Behaviour:

The Pi-hole dashboard shows top-clients both as a name (e.g. as well as an IPv6 address in the ULA fd00:: range.
Given my setup, using conditional forwarding, I would expect the IPv6 ULA addresses to be resolved to host names.

Screenshot 2021-04-01 094543

The configuration:

  • IPv4 and native IPv6 connection from my ISP
  • Fritzbox 7590, FritzOS 7.25, acts as DHCP server
  • Raspberry Pi 3B, Raspberry Pi OS 10 Buster, Pi-hole 5.2.4, Web Interface 5.5, FTL 5.7
  • Pi-hole uses Unbound as upstream DNS resolver
  • Fritzbox uses DHCP reservations so that clients always get the same IPv4 address
  • Fritzbox is set to always assign a IPv6 ULA following these instructions
  • Fritzbox advertises Pi-hole as IPv4 and IPv6 DNS for the Local Network following these instructions

Pi-hole WebGUI Settings - DNS:

  • Never forward non-FQDNs: unchecked
  • Never forward reverse lookups for private IP ranges: unchecked
  • Use DNSSEC: unchecked
  • Use Conditional Forwarding: checked, Local network, IP address of router, Local domain name

Actual Behaviour:

As soon as I restart the DNS resolver (using the WebGUI under Settings - System) the previously seen IPv6 ULA addresses are resolved to names immediately.

I wonder if this is normal?

Is there anything I can change in the Pi-hole settings so that the ULA addresses are always resolved to names without restarting the DNS resolver?

Debug Token:

Two interesting entries in the documentation that might solve your problem:


REFRESH_HOSTNAMES=IPV4 - Do the hourly PTR lookups only for IPv4 addresses This is the new default. Change (or add) this to a setting that suits your needs.

If changing the REFRESH_HOSTNAMES setting (I use UNKNOWN) doesn't solve your problem, you could also try to send a real time signal to FTL.

Signals: Real-time signal 4 (SIG38): Re-resolve all clients and forward destination hostnames.


Do you use fe80:: as DNS server for clients?

I do and all hostname resolve whit fe80::

Thanks, the "refresh hostnames" setting sounds plausible :+1:
I just entered that setting, setting it to UNKNOWN.
I will report back tonight or tomorrow if that solves the issue I am seeing.

No, I use the ULA fd00:: address as that is what Pi-hole shows me under Settings - System.

Setting this to UNKNOWN did the trick, problem solved.
Thanks again!

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.