Rclone mount

The issue I am facing:
When I have my DNS set to pi-hole server, I am unable to get it to mount my rclone drive. I am running pi-hole and rclone on the same pi.
If I only have the DNS of my pi-hole set in the router then it will not mount the rclone drive. If I add a second DNS in my router to or it is fine.

Details about my system:
Pi 4b
running open media vault, pi-hole and rclone
What I have changed since installing Pi-hole:

Assuming your rclone mount uses a target that is accessible via a public domain name, you could check whether that domain is contained in one of the blocklists you've configured for your Pi-hole.
To do so, use pihole -q my.domain.com from a terminal or Tools | Query Lists from Pi-hole's UI.

If it is, exempt the domain that rclone is using from blocking, e.g. by clicking Whitelist on the respective Query Log entry.

Thanks. I checked and it doesn't say it is contained in any lists. The mount is for premiumize

Can you dig the domain rclone is using from your RPi?

I've never used that command before. Is it just "dig [folder name]" where folder name is the mounted rclone drive?

dig operates on domains, e.g.

dig premiumize.me

Substitute premiumize.me above with the exact domain you are using with your rclone.

premiumize.me. 300 IN A
premiumize.me. 300 IN A

is what what dig shows. From following the rclone docs for PM, I can't find any reference to a different domain.

That would suggest that your RPI can at least successfully resolve premiumize.me.

Of course, I cannot know which exact domains your rclone would try to resolve.

You could watch your Query Log for any blocked domains when running your rclone command while Pi-hole is your sole DNS server.

How do I determine what domain an ad is coming from? may also be helpful here.

I tried something else by disabling pi-hole and then rebooting my pi and it still won't mount the rclone

Test 1
Edgerouter DSN1: DNS2:
rclone mounts PM properly

Test 2
Edgerouter DSN1: DNS2: [none]
rclone won't mount PM properly

Test 3
pi-hole set to disabled
Edgerouter DSN1: DNS2: [none]
rclone won't mount PM properly

So I realized that i still had a second DNS in when I did dig on premiumize.me. This is what I got when only DNS was my pi.hole

;; global options: +cmd
;; connection timed out; no servers could be reached

But I get the same error for doing dig google.com .... So am I doing something wrong?

Could you please share the full dig result?

That would suggest your RPi has no DNS server available (so I'd expect any DNS lookup by that RPi to fail).

Run from your RPi, what's the result of

cat /etc/resolv.conf

so not sure if it makes my configuration setup more complicated but I am running pi-hole from a portainer container (within OMV).

if I run the dig command from within the container that is running pi-hole I get: https://pastebin.com/tTRb2t7j

(Please consider copying the results directly in your posts - it makes it easier to read them in context. Use </> Preformatted text from the editor menu.)

We are interested in the DNS resolution that your rclone is potentially failing to succeed at.

That information should be included in your initial post.

The container's resolution isn't relevant (yet).
We are trying to get a hold of DNS resolution of the host that is running your rclone.

Okay thanks. So rclone runs from the pi which is while pi-hole is running from a container that then uses for its webserver admin. I tried posting logs directly but it kept telling me that "referencing users was not allowed" not sure if that is because each command starts with pi @ raspberrypi

Yes, @ is triggering that Discourse behaviour.
That can be avoided by using </> Preformatted text from the editor menu to format the results.

So I'm convinced something was messed up with the container (within OMV) for pi-hole. I only went that route initially because when I installed pi-hole it kept sending me to the webserver for OMV so I couldnt monitor pi-hole. Found online that I could just change the webserver for OMV and now I can use the pi-hole webserver as is. Now it works with rclone without issue. That does lead me to another question, can I change the port for pi-hole's webserver from 80 to something else?

Yes, see Using BLOCKINGMODE=NULL still requires the lighttpd service run on 80? - #3 by Bucking_Horn

Thanks, I really appreciate the help. Is SteveBlack's blacklist the most recommended?