Query on my Setup: Docker on Synology + Merlin Firmware Router


Ok… So in which Setup? Option 1 (net=host) or Option 2 (not as host)… I would like all clients to be showing in DHCP… Do I need to move my DHCP with static list to pi-hole as well?


On your --net=host setup, did you try adding -e DNSMASQ_LISTENING=all and/or -e INTERFACE=<nic>? net=host often requires these from what I’ve gathered (I don’t have experience actually using a synology).

from my README

Advanced/Optional The default works fine with our basic example docker run commands. If you’re > trying to use DHCP with --net host mode then you may have to customize this or DNSMASQ_LISTENING.
Advanced/Optional local listens on all local subnets, all permits listening on internet origin subnets in addition to local.


I think I was missing this… I had this before… But i might have then put this in bridge mode and thought it’s not working (should have been in host mode)

So currently pihole is working, i can see individual hosts IP reported

DHCP is still on the router and I am forwarding DNS via dnsmasq.conf.add file (dhcp-option=6,… On pihole the DNS is pointing to google IPv4


I remember once Pi-Hole stopped working after few hours and thus all of internet died… Is there a failsafe method that if pihole stops responding then go back to router or some other DNS?

@Mcat12 in what way will this be better then my current setup?

Also some of the hosts are showing as resolved names but some are showing IP address… is this due to DHCP not being on Pihole?? shouldn’t be half n half… should be all or none right? for example, nslookup from within the pihole docker does show the resolved name for an IP but the GUI is showing IP address for it…

I am monitoring my traffic atm…

The current setup debug log: ouvbaiph1q

Just in case if anybody wants to see if anything is wrong… and perhaps to compare if pihole goes down / stops serving traffic in next few hours


Just an update… I restarted pihole docker and now none of the IP are resolving to name in hosts list… Even nslookup fails apart from its own IP

root@pihole:/# nslookup
Address: name = pihole.

root@pihole:/# nslookup

** server can’t find NXDOMAIN


If you set the DNS server to Pi-hole instead of messing with the dnsmasq settings, then it eliminates one place where your problem might be coming from. Also, it will let you see client IP addresses.


Done as you suggested… cleared container and files and restarted fresh… still IP are not resolved and nslookup not working

Infact not working from my laptop as well… Nothing internal resolves on nslookup apart from NAS hosting pihole with the name “pihole”



Do I need to move DHCP as well to PiHole? If so I tried couple of things and it broke the “internet”

As you can see DNS is set to (NAS/PiHole)

Did Enable the DHCP Server = No

  • Enabled on PiHole and then set router (gateway) in pihole DHCP to 192.168.100 (Router) - Internet broke - nothing worked had to reset router and restore config
  • Enabled on PiHole and then set router (gateway) in pihole DHCP to 192.168.1 (NAS/PiHole) - Internet broke - nothing worked had to reset router and restore config

If moving DHCP to PiHole is the only method to resolve IP, what will be the best setting?


Can you please condense the current issue you are facing and what you have tried in a new message? It is very difficult to try to piece together what your current situation is from all these posts.

You should set the DHCP range to not include the DNS server or router’s IP addresses.


Ok… All that is fixed… I have set static ip from 1 - 100 and DHCP from 101-254

Currently I have the following issues - all related I think (DHCP my Router with .100 and DNS is Pi/NAS with .1 IP)

  1. nslookup to any internal IP fails except .1 (pihole)
  2. nslookup to external IP works
  3. PiHole showing only IP Address in stats and not resolving to name (due to issue 1)
  4. The pihole/NAS IP is the highest in the client list which is calling its own domain and resolving with OK (Cached) 2 times evert minute on an average

How to fix this ?



any thoughts?


We’re all volunteers who work on this in our own free time, and bumping the thread does not get you to the top of the list, FYI.

  1. Have you set the router or something else with DHCP DNS information as the upstream or similar? Otherwise, Pi-hole has no way of knowing the IP -> hostname client information.
  2. Ok
  3. Same as 1
  4. Is this when you have the web interface open? If you aren’t using pi.hole to connect to the web page, all the requests made to fill the web interface with information will show up as queries.


I bumped so that it doesn’t close in 21 days (did once a week to keep it alive)

router DHCP is set to self and DNS to pihole. I did disable router DHCP and set it to PiHole But then had other issues

I do open the web interface using IP of Pi-Hole (NAS)


If Pi-hole is not running as DHCP and does not have an upstream able to convert IP address lookups into domains, then there is no way for it to perform that duty. What upstream DNS servers are configured for Pi-hole?



The DHCP issue is explained above on what happened when I tried to move DHCP to Pi-hole


You will need to either set the DHCP server as the upstream or conditionally forward local requests to it (assuming it’s also running a DNS server). Conditional forwarding is part of the FTLDNS beta, but you could make a custom Dnsmasq config for it: https://github.com/pi-hole/FTL/issues/248#issuecomment-377803065

Otherwise, you will have to use Pi-hole for DHCP if you want to resolve hostnames.


If I get what you mean… I did that already and have the problems as mentioned in Query on my Setup: Docker on Synology + Merlin Firmware Router


You didn’t say if you set the Pi-hole’s upstream DNS to the router or did the conditional forwarding I linked.


Sorry I don’t think I understand what I am suppose to do here

I believe the Pi-Hole Upstream DNS is set to google?

So my setup is DNS in router set to PiHole (Screenshot above)… and in PiHole DNS set to Google

DHCP is active in Router… When I disable it and set it to Pihole… I tried both cases (as mentioned above) where I enabled DHCP in PiHole and set router (gateway) to Router IP and fails, and setting router (Gateway) as PiHole fails


As I understand won’t think be google? If i set it to router… and router pointing to Pi-Hole then they will go in the loop? What do u mean by “upstream DNS”? Is there “Downstream DNS” as well?

My setup is explained in previous post. If you can point what to do exactly for setup, that would be great… :pray:


I explained that you need to set Pi-hole’s upstream to the router, so that it can be used by Pi-hole to resolve the local hostnames. The router itself should use a different upstream, such as Google, but hand out Pi-hole to DHCP clients.

There’s another solution where you use the conditional forwarding option in the FTLDNS beta and only forward .local domains to the router.

I have tried giving you the knowledge and tools to fix your network, and you have more knowledge about how it is set up than me, so this will be my last post in this thread. I can not tell you exactly what you need because I do not know exactly what you need, but you have the tools to figure that out.