Query on my Setup: Docker on Synology + Merlin Firmware Router


#22

Ok… So in which Setup? Option 1 (net=host) or Option 2 (not as host)… I would like all clients to be showing in DHCP… Do I need to move my DHCP with static list to pi-hole as well?


#23

On your --net=host setup, did you try adding -e DNSMASQ_LISTENING=all and/or -e INTERFACE=<nic>? net=host often requires these from what I’ve gathered (I don’t have experience actually using a synology).

from my README

-e INTERFACE=<NIC>
Advanced/Optional The default works fine with our basic example docker run commands. If you’re > trying to use DHCP with --net host mode then you may have to customize this or DNSMASQ_LISTENING.
-e DNSMASQ_LISTENING=<local|all|NIC>
Advanced/Optional local listens on all local subnets, all permits listening on internet origin subnets in addition to local.


#24

I think I was missing this… I had this before… But i might have then put this in bridge mode and thought it’s not working (should have been in host mode)

So currently pihole is working, i can see individual hosts IP reported

DHCP is still on the router and I am forwarding DNS via dnsmasq.conf.add file (dhcp-option=6,192.168.1.1)… On pihole the DNS is pointing to google IPv4

Now

I remember once Pi-Hole stopped working after few hours and thus all of internet died… Is there a failsafe method that if pihole stops responding then go back to router or some other DNS?

@Mcat12 in what way will this be better then my current setup?

Also some of the hosts are showing as resolved names but some are showing IP address… is this due to DHCP not being on Pihole?? shouldn’t be half n half… should be all or none right? for example, nslookup from within the pihole docker does show the resolved name for an IP but the GUI is showing IP address for it…

I am monitoring my traffic atm…

The current setup debug log: ouvbaiph1q

Just in case if anybody wants to see if anything is wrong… and perhaps to compare if pihole goes down / stops serving traffic in next few hours


#25

Just an update… I restarted pihole docker and now none of the IP are resolving to name in hosts list… Even nslookup fails apart from its own IP

root@pihole:/# nslookup 192.168.1.1
Server: 192.168.1.1
Address: 192.168.1.1#53

1.1.168.192.in-addr.arpa name = pihole.

root@pihole:/# nslookup 192.168.1.2
Server: 192.168.1.1
Address: 192.168.1.1#53

** server can’t find 2.1.168.192.in-addr.arpa: NXDOMAIN


#26

If you set the DNS server to Pi-hole instead of messing with the dnsmasq settings, then it eliminates one place where your problem might be coming from. Also, it will let you see client IP addresses.


#27

Done as you suggested… cleared container and files and restarted fresh… still IP are not resolved and nslookup not working

Infact not working from my laptop as well… Nothing internal resolves on nslookup apart from NAS hosting pihole with the name “pihole”


#28

bump

Do I need to move DHCP as well to PiHole? If so I tried couple of things and it broke the “internet”

As you can see DNS is set to 192.168.1.1 (NAS/PiHole)

Did Enable the DHCP Server = No
Then

  • Enabled on PiHole and then set router (gateway) in pihole DHCP to 192.168.100 (Router) - Internet broke - nothing worked had to reset router and restore config
  • Enabled on PiHole and then set router (gateway) in pihole DHCP to 192.168.1 (NAS/PiHole) - Internet broke - nothing worked had to reset router and restore config

If moving DHCP to PiHole is the only method to resolve IP, what will be the best setting?


#29

Can you please condense the current issue you are facing and what you have tried in a new message? It is very difficult to try to piece together what your current situation is from all these posts.

You should set the DHCP range to not include the DNS server or router’s IP addresses.


#30

Ok… All that is fixed… I have set static ip from 1 - 100 and DHCP from 101-254

Currently I have the following issues - all related I think (DHCP my Router with .100 and DNS is Pi/NAS with .1 IP)

  1. nslookup to any internal IP fails except .1 (pihole)
  2. nslookup to external IP works
  3. PiHole showing only IP Address in stats and not resolving to name (due to issue 1)
  4. The pihole/NAS IP is the highest in the client list which is calling its own domain and resolving with OK (Cached) 2 times evert minute on an average

How to fix this ?


#31

bump

any thoughts?


#32

We’re all volunteers who work on this in our own free time, and bumping the thread does not get you to the top of the list, FYI.

  1. Have you set the router or something else with DHCP DNS information as the upstream or similar? Otherwise, Pi-hole has no way of knowing the IP -> hostname client information.
  2. Ok
  3. Same as 1
  4. Is this when you have the web interface open? If you aren’t using pi.hole to connect to the web page, all the requests made to fill the web interface with information will show up as queries.

#33

I bumped so that it doesn’t close in 21 days (did once a week to keep it alive)

router DHCP is set to self and DNS to pihole. I did disable router DHCP and set it to PiHole But then had other issues

I do open the web interface using IP of Pi-Hole (NAS)


#34

If Pi-hole is not running as DHCP and does not have an upstream able to convert IP address lookups into domains, then there is no way for it to perform that duty. What upstream DNS servers are configured for Pi-hole?


#35

Google

The DHCP issue is explained above on what happened when I tried to move DHCP to Pi-hole


#36

You will need to either set the DHCP server as the upstream or conditionally forward local requests to it (assuming it’s also running a DNS server). Conditional forwarding is part of the FTLDNS beta, but you could make a custom Dnsmasq config for it: https://github.com/pi-hole/FTL/issues/248#issuecomment-377803065

Otherwise, you will have to use Pi-hole for DHCP if you want to resolve hostnames.


#37

If I get what you mean… I did that already and have the problems as mentioned in Query on my Setup: Docker on Synology + Merlin Firmware Router