Qnap Container Station Docker Host Volume Issue


I've installed Pihole using the latest docker image from the Qnap Container Station.

The only changes to the standard configuration are to set the networking to bridged with a static IP and to map the two folders for pihole and dnsmasq.d to host folders.

The install completes but Pihole doesn't work at all (the admin web page loads but there is no login option and I see errors on the settings screens) and I see the following errors during installation in the terminal:

  [i] Existing dnsmasq.conf found... it is not a Pi-hole file, leaving alone!
  [i] Copying 01-pihole.conf to /etc/dnsmasq.d/01-pihole.conf...
  [✓] Copying 01-pihole.conf to /etc/dnsmasq.d/01-pihole.conf
chown: cannot access '': No such file or directory
chmod: cannot access '': No such file or directory
chown: cannot access '/etc/pihole/dhcp.leases': No such file or directory
Configuring default DNS servers:,

Here is the error I get on the settings page:

I have searched around and this looks like permissions errors based on something Qnap is doing with Container Station but I cannot work out exactly the issue is and how to resolve it.

Please can someone help me?

I've done some more digging but I have still not found a solution - has anyone else tried this with any success or any support for me?

Note this works in LXC for me so it looks to be a Docker specific issue.