Problems 0 domains on fresh install?

So I recently updated my router and for some reason,it couldn't find my raspberry pi 1 running pi hole anymore. So I reinstalled the pi and put the latest pi hole on it. I added some new lists and updated but something happend. CPU usage got to 100% and memory as well. I figured I had used to many domains, around 3 million. So I reinstalled the pi again, this time only using the built in lists that come with 4.0. Now the pi works like normally, it is fast and uses a small amount of cpu and memory but there are no domains on the blocklist, it says 0. If I go to Tools>update Gravity and press update. It will load for a couple of minutes and then say " [✗] DNS resolution is currently unavailable
[✗] DNS resolution is not available"
but it still works, the dns is active and the pi hole routes request.

What do I do? I've never had this problem on previous versions of Pi Hole.

EDIT: So it seems that the problem was that I had already set my Router to point at the pi hole. Changing that dns setting to just seemed to solve it, now pi hole works properly! However upon changing the router's dns setting back to the pi hole results in the same thing, gravity cannot update! So I guess I will have to set and reset this setting once a month manually to get it working again?

Please send us the token generated by

pihole -d

or do it through the Web interface:

I edited my first post. Seems that I now have to set and reset my routers dns settings every time to update my lists?

You should not have to do this. Post your debug token and we will look at your debug log for problems.

I don't see how this can be the case. If you have your router set to use Cloudflare as the DNS, none of the traffic is going to Pi-Hole (you are bypassing it).

Maybe I am bad at explaining.

At first my router was set to use the pi, Then when I logged into the pi, I could not update the lists.

Then I logged back into the router and changed it to use Then I went to the pi and it updated just fine.

Then I changed back to again and updating lists broke again. However I can see that I am now routing dns requests to the pi so I am not sure what is causing this. I generated the debug file but I cannot find the token. I get a message at the end saying that there was an error uploading your debug log. Maybe this is due to the error above. I bet that if I changed my router dns to again it would work..

Starting to consider rolling back to previous version of pi hole, never had these issues before. :S

The file you should edit is /etc/resolv.conf on the Pi.

  1. sudo nano /etc/resolv.conf
  2. edit to or your preferred third party DNS service
  3. save
  4. Re-run pihole -up
1 Like

Tried it, doesn't work. Still get DNS resolution is currently unavailable.

Repeat the changes to /etc/resolve.conf, but follow with a pihole repair:

pihole -r and select the "repair" option.

Tried it. Everything checked out just fine, then I got a message saying software error caused reboot and now I can't SSH into it anymore or reach the web interface. :S

This is likely a software or hardware issue on the Pi-Hole host. Look in your router and see if the Pi is connected to the network. Alternately, you can download PiFinder from Adafruit (it's a handy utility to find a Pi on your network without knowing the IP address of the Pi).

Yeah its not there, similarly to when it disappeared when I updated the router. I'm beginning to think maybe my sd card is toast?

It's not very expensive to get a new card. For $10 or so US, you can get a nice 32 GB card with plenty of space.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.