Probleme beim installieren der FTLDNS Beta


#1

Guten Morgen,

ich versuche gerade in einer VM die FTLDNS Beta zu installieren und bekomme die Fehlermeldung:

X Fetching branches from https://github.com/pi-hole/pi-hole.git

Woran kann es liegen das die .git nicht gefunden wird? Sonst funktioniert alles (QNAP VM - DietPi, aktuelle Version von Pi-hole)


#2

Funktioniert die Internetverbindung?

Vielleicht etwas konkreter: Funktioniert dig github.com ?


#3

Internetverbindung und dig github.com funktionieren…

; <<>> DiG 9.10.3-P4-Debian <<>> github.com
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 52423
;; flags: qr rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 512
;; QUESTION SECTION:
;github.com.                    IN      A

;; ANSWER SECTION:
github.com.             59      IN      A       192.30.253.113
github.com.             59      IN      A       192.30.253.112

;; Query time: 64 msec
;; SERVER: 127.0.0.1#53(127.0.0.1)
;; WHEN: Wed Jun 13 09:59:11 BST 2018
;; MSG SIZE  rcvd: 71

#4

Was sagt

cd /etc/.pihole
git remote set-branches origin '*'
git fetch

?


#5

Alle Befehle gehen durch ohne Fehlermeldung


#6

Ich habe gerade mal auf den aktuellen DEV Branch umgeswitcht - gleiches Problem. Ich bin ein wenig ratlos…


#7

Muss natürlich nicht, aber besteht hier eine Gemeinsamkeit?


#8

@mibere - Ich habe mir das Topic durchgelesen, dieses Problem habe ich nicht.

Ich habe gerade alles nochmal neu installiert, sowohl beim Master Branch als auch bem Dev Branch bekomme ich weiterhin die Fehlermeldungen:

  [✗] Fetching branches from https://github.com/pi-hole/pi-hole.git
  [✗] Fetching branches from https://github.com/pi-hole/AdminLTE.git

Sehr seltsam…


#9

Nach dem Update gerade habe ich jetzt als Versionsangabe: FTL Version vDev (FTLDNS, vDev-5ecab0a)

Heißt das, daß FTLDNS installiert ist und scharfgeschaltet?


#10

Da dies die gleiche Anzeige wie in meinem Webinterface ist, und ich ebenfalls mit FTLDNS unterwegs bin … ja.

Zusätzlich kannst du dies u.a. hiermit überprüfen:

sudo systemctl is-enabled dnsmasq.service

Du solltest dies erhalten:

disabled


#11

Passt - dann kann ich jetzt in Ruhe testen bevor ich die VM scharf schalte :wink: