Problem with Rasbian / Bullseye

I already upgraded my rasbian to bullseye. When i try to upgrade "core" to beta v5.4, this is the output:

root@raspberrypi2:~# pihole checkout core release/v5.4
Please note that changing branches severely alters your Pi-hole subsystems
Features that work on the master branch, may not on a development branch
This feature is NOT supported unless a Pi-hole developer explicitly asks!
Have you read and understood this? [y/N] Y


[✓] Checking for dnsutils

[✗] Unsupported OS detected: Raspbian 11
If you are seeing this message and you do have a supported OS, please contact support.

  If you wish to attempt to continue anyway, you can try one of the following commands to skip this check:

  e.g: If you are seeing this message on a fresh install, you can run:
         curl -sSL | PIHOLE_SKIP_OS_CHECK=true sudo -E bash

       If you are seeing this message after having run pihole -up:
         PIHOLE_SKIP_OS_CHECK=true sudo -E pihole -r
       (In this case, your previous run of pihole -up will have already updated the local repository)

  It is possible that the installation will still fail at this stage due to an unsupported configuration.
  If that is the case, you can feel free to ask the community on Discourse with the Community Help category:

Error: Unable to complete update, please contact support

This is expected and independent of the Pi-hole version you are running.

Bullseye is not yet a supported OS. We are working on supporting this OS, but Bullseye has not yet been released in final form.

1 Like

There are also other issues with Bullseye that are not yet solved.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.