Problem on RealMe 6 device (Android)

Expected Behaviour:

PiHole is working on my Android Phone. (Android 10, RealMe 6)

Actual Behaviour:

PiHole is not working on my Android Phone.

Hey guys,
I recently got a new phone because my old one broke. Problem is, PiHole doesn't work on my new device. It is working on my PC, laptop and on other Android phones or iPhones. But for some reason it does not work on my RealMe 6. Whether it's on Firefox, Chrome or in Apps.
Of course I changed the DNS in the setting to PiHole DNS. I also tried using an DNS Changer App. I can access the Web Interface from my phone. It also shows up on there in the client section. But no actual website or app requests go through. Just stuff like this: //

I really don't know what could be the cause and how to fix it.
Thanks in advance!

Nobody knows what to do? :frowning:

Does it show up as using pihole?

Yes, it says that it's using pi-hole. But for some reason, not all of the devices request go through.
Here are the most recent ones:

I don't understand.

The phone is using Pihole; Pihole then forward the request upstream and returns the IP to your phone.

What makes you think, there is a problem?

The thing is, it's not forwarding everything. It's not blocking ads and I can visit websites I put on the blacklist too. Normally on phones there are a lot of analytics or crash requests blocked by pi-hole too, they don't show up either.
I don't understand it either.

This sounds like an IPv6 issue. Maybe your phone uses IPv6 to bypass pihole. Another things would be something like "secure DNS"/"private DNS" where your phone uses DoT - and queries would not show up in Pihole.

Maybe that's what's happening.

Although IPv6 is enabled in PiHole and private DNS is disabled in the Android settings. Anything else I need to make sure of?

Thank you for trying to help me by the way.

No more ideas. In chrome browser you should disable DoH.

Install a network information app on the phone to see what DNS servers its using.
I also suspect an IPv6 leak.

One app says

DNS1: (Pi-Hole)
DNS2: (Pi-Hole)

I installed another app just to make sure. It says

I don't know why it says there because in the settings I got both the primary and the secondary set to Pi-Holes DNS.
The second app also says DNS Server IPv6 = N/A

Ooow I dont know who to trust.
But second guessing, the second app shows correct ones.
Easy to figure out by just disconnecting Pi-hole from network.
If the Android device is still able to browse the Internet, you know its using something other than Pi-hole for DNS.

Yep, I shut off Pi-Hole and I couldn't access sites on my PC but on my phone I still could.
It's so weird, the phone shows up in Pi-Holes network tab as using Pi-Hole and some request go through but it's not actually using it.

I don't know what to do to make it use Pi-Hole properly. Didn't have those issues on my last phone.

Could disable the DHCP service on the router and enable the one on Pi-hole as a replacement:

That way your sure connected clients will receive proper DNS server (Pi-hole IP) assigned through DHCP.
Enable Pi-hole's DHCP service first before you disable the one on the router!
And reboot the Android device after to be sure.

I was doing that on my last Pi-Hole installation and it didn't work.

Last night I reinstalled Pi-Hole completely to maybe fix it and this time I didn't use it as an DHCP server. But it still doesn't work.

I also just tried using it as an DHCP server again, but same results sadly.

I dont have other easy solutions for this particular problem.
If have an outbound firewall solution, you could redirect all DNS ports 53 udp/tcp outbound to your DNS server of choice.
But thats not an easy one if not familiar.

Dang, thank you for trying to help anyway.

1 Like

Okay, for anyone with the same problem:

I got it to work by just blocking port 53 for my phone on my router.

Now everything is working properly.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.