Please help trying to put pi-hole in synology nas


#1

Expected Behaviour:

fresh install Pi-hole and DNS Server is not runing
i could go to Pi-hole web page, but shows Lost connection to API
i was only trying to use pi-hole to block ads, and my apologies, i dont have muck knowledge on coding.

Actual Behaviour:

[✗] Starting DNS forwarder and DHCP server: dnsmasq
dnsmasq: extraneous parameter at line 37 of /etc/dnsmasq.d/01-pihole.conf
failed!
pihole-FTL: no process found

[✗] DNS service is NOT running
View the web interface at http://pi.hole/admin or http://192.168.1.88/admin

You may now configure your devices to use the Pi-hole as their DNS server
[i] Pi-hole DNS (IPv4): 192.168.1.88
If you set a new IP address, please restart the server running the Pi-hole

[i] The install log is located at: /etc/pihole/install.log
Installation Complete!

when i try to start dnsmasq error came back

root@Synology:/# sudo service dnsmasq restart
[FAIL] Restarting DNS forwarder and DHCP server: configuration syntax check failed!

Debug Token:

l7nvgrbutd

i hope this is all info i need to provide, if not please let me know, and i will try to get it update, any help would be appreciated

thanks,
Sam


#2

Your version of dnsmasq probably doesn’t support the =extra flag needed for Pi-hole v3.3.


#6

update again, i had done installing from zero, all light in web ui is green, however no internet access if i change DNS to mine.

i change my phone’s DNS to 192.168.1.88, but Web UI for pi-hole still shows (0clients)

token: 45jjugluf2

thanks:slight_smile:


#7

i have done both way from your post, stil have the same result

root@Synology:/var/www/html/admin# sudo service dnsmasq restart
[FAIL] Restarting DNS forwarder and DHCP server: configuration syntax check failed!

however now on Web UI i can see numbers on Domain on Blocklist, but still indicate (0 clients), when i change DNS on my phone, it has internet access, but not blocking ad on youtube.

new token 2ldct3p29d

thanks for your help Jacob,

Sam


#8

As I mentioned, your /etc/dnsmasq.d/01-pihole.conf has this line

log-queries=extra

which needs to be

log-queries

because Jessie cannot currently support v3.3 of Pi-hole.


#9

thanks alot Jacob, fixed the line, now pi hole can see there is a device connect to it as DSN server,
thank you a lot.


#10

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.