PiHole working but not blocking

Please follow the below template, it will help us to help you!

Hello everyone

I installed PiHole on an Ubuntu server (Ubuntu 18.04.3 LTS) inside a VM on FreeNas. I both putted an static ip on my Nas and my PiHole I can both ping to google.com. I can connect to the web ui and I can see it’s blocking not so much queries (4 after a few hours after install). When I do pihole status in the server terminal I get it’s blocking and the DNS service is running.

Expected Behaviour:

PiHole blocking ads

Actual Behaviour:

PiHole’s web UI is werking fine and it says it’s blocking queries but doesn’t actually block things since i’m testing so called “adblock testers”

Debug Token:

ikx5wsqkhb

Your debug log shows that Pi-Hole is correctly receiving and blocking domains, but it does not appear to be getting many requests, as you noted. This usually indicates a configuration problem in your router or network clients, resulting in them using a DNS other than Pi-Hole.

From the terminal or command prompt on a client that you believe is using Pi-Hole, run the following command and post the output:

nslookup pi.hole

If the client is a PC, post the output of the following and also indicate which of the interfaces the PC is using:

ipconfig /all

Do I just have to do nslookup pi.hole or do nslookup pi.hole (and ip here pi hole) because I get something random of my internet provider that i can’t find pi.hole and says “Non-existent domain” and when I do it with the ip I get it found a pihole server with the static ip i gave it and then ipv6 address but what do you need exactly of the ipconfig /all because I don’t what is safe to give and what not

This is the correct command to type. From your description, that client is not using Pi-Hole for DNS. Since it isn’t using Pi-Hole DNS, the DNS resolver cannot resolve the domain pi.hole, since that is only known by the Pi-Hole itself.

When a client is properly configured for Pi-Hole, the output of the command will look something like this. The DNS server that responded was Pi-Hole at IP 155, and the correct answer for the IP of the domain pi.hole is also 155, since that is the same device.

nslookup pi.hole

Server: 192.168.0.155
Address: 192.168.0.155#53

Name: pi.hole
Address: 192.168.0.155

Your router is providing an alternate DNS IP to the clients. Check all the router settings and disable IPv6 on the router as well. IPv6 is a frequent cause of DNS bypasses.

You can PM me the output of ipconfig /all

Ok I’ll take a look at it. Here’s a output of my ipconfig /all:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Intel(R) Ethernet Connection (2) I219-V
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes
   IPv4 Address. . . . . . . . . . . : 192.168.0.4(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . : 192.168.0.1
   DNS Servers . . . . . . . . . . . : 192.168.0.7
   NetBIOS over Tcpip. . . . . . . . : Enabled

this is it after messing around with the DNS settings of my pc an putting of ipv6 but still same results

With these settings on that client, what is the output of nslookup pi.hole from that client?

it gives me this:
Server: pihole
Address: 192.168.0.7

Name: pi.hole
Addresses: 2a02:1810:531:ac00:2a0:98ff:fe42:d8c0
192.168.0.7

This appears correct. That client is using Pi-Hole for DNS.

What is the output of nslookup flurry.com

Server: pihole
Address: 192.168.0.7

Name: flurry.com
Addresses: ::
0.0.0.0

I was just looking at the site I was using on this site it appears to not work: http://simple-adblock.com/faq/testing-your-adblocker/
and on this one I thinks it working:https://ads-blocker.com/
or does pihole not succeed for that site?

Also I just noticed on my web UI it says now it has total of 575 queries

Which 54 of them are blocked. So I gues it’s some sort of fixed?

This is the correct output. The domain flurry.com is blocked on the default Pi-Hole block lists, so the correct reply is 0.0.0.0 and the matching IPv6 reply for NULL. Pi-Hole is correctly configured for use on this client.

I would try instead to load a domain that is known to have a lot of ads that can be blocked by Pi-Hole. cnn.com is such a domain.

If you do see ads there or on other sites, here are some tools to help find out where the ads are served from.

Ok thank you for helping and I don’t get ads cnn.com and also checked it on my phone and got the same result so it’s fixed I gues.

Hello everyone, did you get the answer you want? However, I have a small question to ask you if it is possible. Thank you for your return  Force to us. Sincerely

Yes I got the answer I needed. It works now I see it’s blocking more queries so that’s good and yesterday it wasn’t doing anything at all

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.