Pihole with AX10 Archer router, LAN changes

Devices:
raspberry pi 4, 4gb - 192.168.1.10
TP-Link AX1500 - 192.168.1.1

What i'm trying to do is the following:
make my router's DNS point to pihole, (which in fact is running) by setting the DNS in DHCP to my pihole's IP address.

Given in this picture:

Now, this doesn't do anything i'd like it to. The devices are not using it as my DNS server and I can verify this by looking at the pihole logs, which keep clear except for the device itself.

Now there is a setting in the router within Internet which also gives a DNS server and I can edit this, but once I do, the LAN IP changes to 192.168.0.1 and the network is no longer running as it should because the DNS is pointing to 192.168.1.10. when, in turn, i try to change this IP address to 192.168.0.10 for instance, the LAN IP changes back to 192.168.1.1. And this goes on.
What's happening?

by the way. When i try to use my pihole as DHCP server(disable on the router, enable on pihole), well... i have to reset my router because no device is any longer connecting correctly.

what can i do? what am i missing here?

Setting Pi-hole as "Primary DNS" in the DHCP Server tab sounds like a good approach. Did you dis/reconnect your clients to the network after you made changes in the DHCP settings? Otherwise they won't pick up changes...

Please upload a debug log and post just the token that is generated after the log is uploaded by running the following command from the Pi-hole host terminal:

pihole -d

or do it through the Web interface:

Tools > Generate Debug Log

Hi,

Here is my token: https://tricorder.pi-hole.net/mk0stu408i

I also toke a look at my wifi properties of my laptop where I found out that indeed my laptop is using the PI as DNS:

Side note: you're using nginx which is a not-supported web server

[80] is in use by nginx (https://docs.pi-hole.net/main/prerequisites/#ports)
*:8080 nginx (IPv4)
*:81 nginx (IPv4)
*:443 nginx (IPv4)
[80] is in use by nginx (https://docs.pi-hole.net/main/prerequisites/#ports)
*:8080 nginx (IPv4)
*:81 nginx (IPv4)
*:443 nginx (IPv4)
[80] is in use by nginx (https://docs.pi-hole.net/main/prerequisites/#ports)
*:8080 nginx (IPv4)
*:81 nginx (IPv4)
*:443 nginx (IPv4)
[80] is in use by nginx (https://docs.pi-hole.net/main/prerequisites/#ports)
*:8080 nginx (IPv4)
*:81 nginx (IPv4)
*:443 nginx (IPv4)
[80] is in use by nginx (https://docs.pi-hole.net/main/prerequisites/#ports)

Your router advertises itself and Pi-hole via DHCP as DNS server. You should configure to only advertise your Pi-hole, otherwise your clients will bypass Pi-hole.

*** [ DIAGNOSING ]: Discovering active DHCP servers (takes 10 seconds)
   Scanning all your interfaces for DHCP servers
   Timeout: 10 seconds
   
   * Received 300 bytes from eth0:192.168.1.1
     Offered IP address: 192.168.1.10
     Server IP address: 192.168.1.1
     Relay-agent IP address: N/A
     BOOTP server: (empty)
     BOOTP file: (empty)
     DHCP options:
      Message type: DHCPOFFER (2)
      server-identifier: 192.168.1.1
      lease-time: Infinite
      netmask: 255.255.255.0
      broadcast: 192.168.1.255
      dns-server: 192.168.1.10
      dns-server: 192.168.1.1
      router: 192.168.1.1
      --- end of options ---

Hi,

Yes, i use nginx but for another use case. In my belief, pi-hole is running at lighttpd on port 86 in the system!

do I have to change a port on pi-hole itself as well? i only configured lighttpd on 86 for this.

Maybe a rookie question, but how can i set my router to only advertise pi-hole?

You're right. I was to quickly skimming over the port list.


This depends on your router model. Judging from the screenshots above, it looks like you only entered "Primary DNS". You can try to enter Pi-holes IP as "Secondary DNS" as well and see if it suppresses the router's own IP as DNS server.

If not, you could disable the router's DHCP server and use Pi-hole's built-in DHCP server.

Thanks, i will try to do the first. The 2nd is what i'd like most but that's where issues start to happen as described in the top post.

Ok, so what happens now is even worse haha.

I set both to route to my pihole...
Pihole log is not updating and my laptop won't connect to any new website. this website works though. (cached dns?)

So, I did IP release and renew, rebooted all the devices and router, but still most sites won't work. Neither does my pihole have any new requests in the query log so I think that somehow it doesn't respond to dns requests.

Taking that into account I figured something is blocking requests and one thing that could do this was ufw. I added the UFW ports and result. now it works!

I feel stupid but found the solution :slight_smile:

Thanks for the help!

Glad it worked :slight_smile:

1 Like