Pihole -up wants to add Ubuntu's universe repo to Raspbian Buster?

Please follow the below template, it will help us to help you!

Please ensure that you are running the latest version of the beta code.
Run pihole -up to update to the latest, then verify that the problem still exists before reporting it.

Problem with Beta 5.0:

running pihole -up yesterday worked fine but today running pihole -up presents me with the following.

selecting yes results in the following error

  [i] Enabling universe package repository for Ubuntu Bionic
  [✓] Backed up current configuration to /etc/apt/sources.list.backup
Traceback (most recent call last):
  File "/usr/bin/add-apt-repository", line 95, in <module>
    sp = SoftwareProperties(options=options)
  File "/usr/lib/python3/dist-packages/softwareproperties/SoftwareProperties.py", line 109, in __init__
  File "/usr/lib/python3/dist-packages/softwareproperties/SoftwareProperties.py", line 599, in reload_sourceslist
  File "/usr/lib/python3/dist-packages/aptsources/distro.py", line 93, in get_sources
    (self.id, self.codename))
aptsources.distro.NoDistroTemplateException: Error: could not find a distribution template for Raspbian/buster

  Unable to complete update, please contact Pi-hole Support

not sure why it's trying to enable universe package repository for Ubuntu Bionic as I'm using

output of cat /etc/os-release

PRETTY_NAME="Raspbian GNU/Linux 10 (buster)"
NAME="Raspbian GNU/Linux"
VERSION="10 (buster)"

output of uname -a

Linux ns1 4.19.97-v7l+ #1294 SMP Thu Jan 30 13:21:14 GMT 2020 armv7l GNU/Linux

I don't have any Ubuntu sources enabled. I use the WireGuard repo since I can't seem to get WireGuard any other way but i don't use any sources that provide default Ubuntu packages.

content of /etc/apt/sources.list

deb http://raspbian.raspberrypi.org/raspbian/ buster main contrib non-free rpi
# Uncomment line below then 'apt-get update' to enable 'apt-get source'
deb-src http://raspbian.raspberrypi.org/raspbian/ buster main contrib non-free rpi

# deb http://ppa.launchpad.net/qbittorrent-team/qbittorrent-stable/ubuntu bionic main 
# deb-src http://ppa.launchpad.net/qbittorrent-team/qbittorrent-stable/ubuntu bionic main 

# deb http://ppa.launchpad.net/wireguard/wireguard/ubuntu bionic main 
# deb-src http://ppa.launchpad.net/wireguard/wireguard/ubuntu bionic  main

output of pihole -v

  Pi-hole version is release/v5.0 v4.3.5-493-g393c773 (Latest: v4.4)
  AdminLTE version is release/v5.0 v4.3.2-488-g34d9942 (Latest: v4.3.3)
  FTL version is release/v5.0 vDev-5ad55e8 (Latest: v4.3.1)

Debug Token:

What's in /etc/apt/sources.list.d/?

That's what is triggering it. I'll see if we can ignore commented lines, but really you shouldn't have bionic repos on buster.

/etc/apt/sources.list.d $ ls -la
total 24
drwxr-xr-x 2 root root 4096 Apr 25 16:49 .
drwxr-xr-x 7 root root 4096 Apr 28 14:17 ..
-rw-r--r-- 1 root root   74 Apr 25 16:49 docker.list
-rw-r--r-- 1 root root   90 Apr 15  2019 nordvpn.list
-rw-r--r-- 1 root root   60 Apr 20 16:55 pivpn-bullseye.list
-rw-r--r-- 1 root root  187 Feb 13 09:57 raspi.list

/etc/apt/sources.list.d $ cat docker.list
deb [arch=armhf] https://download.docker.com/linux/raspbian buster stable
/etc/apt/sources.list.d $ cat nordvpn.list
# NordVPN releases, stable
deb https://repo.nordvpn.com/deb/nordvpn/debian stable main
/etc/apt/sources.list.d $ cat pivpn-bullseye.list
deb http://raspbian.raspberrypi.org/raspbian/ bullseye main
/etc/apt/sources.list.d $ cat raspi.list
deb http://archive.raspberrypi.org/debian/ buster main
# Uncomment line below then 'apt-get update' to enable 'apt-get source'
#deb-src http://archive.raspberrypi.org/debian/ buster main

Can confirm removing those line fixed the issue

@bcambl Should we do bionic and focal or what ever 20.04 is named? Might as well get both in the same PR.

I think you @ the wrong handle :stuck_out_tongue_closed_eyes:

1 Like