Pihole -up ends in Error "Unable to complete"

Running OS: Raspbian Bullseye
Hardware: AsusEee PC 1215N
Performing regular upgrade routine as always for more than four Years now

After performing pihole -up
it exits after "restarting pihole-ftl service" saying:
unable to complete update, please contact Pi-hole Support.

now the Pi-hole still responds to its Static IP Adress.
The Management Homepage is still working just fine.
It just Shows "DNS Service not running"

I ran pihole -r twice.
Once automatic and after rebooting and having the same problem
ran pihole -r again configuring the Pihole manually.
Still it hangs at the same spot.
Now i saw, that it managed to snatch another IP Adress from the DHCP Server? Not sure what to think about this, since it still responds to its static IP Adress.

Debug Token:

https://tricorder.pi-hole.net/C51zlaYE/

[✗] udp:127.0.0.1%lo:53 is in use by connmand (https://docs.pi-hole.net/main/prerequisites/#ports)

   [2022-09-21 10:55:06.030 988M] FATAL ERROR in dnsmasq core: failed to create listening socket for port 53: Die Adresse wird bereits verwendet

Pi-hole needs to bind to port 53. You need to disable connmand

Thank you for your fast reply. :grinning:
Following this discussion

i ran
apt purge connman && reboot
now the Raspbian went dark on me.
Since i am remote configuring this machine i will have to wait until i can get to it physically to see what it is doing.
This will take a few days.
Until then

From yesterday :wink:

This needed another reboot for whatever reason.

connman is now not longer available. But Pihole runs as always :slight_smile: