Pihole -up - bad URL for FTL v4.2.3

#1

Please follow the below template, it will help us to help you!

Expected Behaviour:

Running pihole -up update FTL

Actual Behaviour:

[i] Downloading and Installing FTL…curl: (22) The requested URL returned error: 404
[✗] Downloading and Installing FTL
Error: URL https://github.com/pi-hole/FTL/releases/download/v4.2.3/tbd not found

Debug Token:

https://tricorder.pi-hole.net/kxb8plas0k!

It seems that the -up process is trying to download from a directory (/tbd) which is a placeholder. The command does work
curl -sSL https://github.com/pi-hole/FTL/releases/download/v4.2.3/pihole-FTL-arm-linux-gnueabihf -o pihole-FTL

0 Likes

#2

You are running on the dev branch of FTL.

*** [ DIAGNOSING ]: FTL version
[✓] FTL: vDev-aae487e (https://discourse.pi-hole.net/t/how-do-i-update-pi-hole/249)

Run the following to move FTL to the master and get the latest version:

pihole checkout ftl master

Edit - just noticed in your debug log that you are running Wheezy, which is an old Raspbian version no longer supported by Pi-Hole.

You need to be on Raspbian Jessie or Stretch (Stretch is recommended).

https://docs.pi-hole.net/main/prerequesites/

0 Likes

#3

OK, not sure how I got on the dev branch. I was just running pihole -up, and that was the version it was pulling.

So I ran the command. It completed. I reran pihole -up, still get the same error as before. FTL shows offline. So I tried

service pihole-FTL restart

But I get the following error

dnsmasq: failed to create listening socket for port 53: Address already in use
Notice: Found no readable FTL config file

So not sure what to try next.

P.S. And I set this pi up probably 3+ years ago, so not surprising I am on an older version

0 Likes

#4

I think your success path is to change the OS on the Pi to Stretch, then reinstall Pi-Hole with the curl command. It doesn’t look like you have much other software running on the Pi.

0 Likes

#5

OK, thanks. I guess I should have not tried to upgrade pihole, just left it well enough alone. :wink:

0 Likes

#6

Sooner or later it would have failed, with the combination of an unsupported OS and an older version of FTL.

0 Likes

closed #7

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

0 Likes