PiHole, Stubby, Fritzbox und Lokale Namensauflösung


#1

Servus miteinand,

ich hab seit ein paar Tagen das Problem, dass ein Teil meiner lokalen PCs nicht mehr über ihren Hostnamen gefunden werden können, ein anderer Teil schon und ich weiß nicht, woran es liegt…

Ich hab einen ESXi Server, auf dem zwei VMs laufen (Windows 10 und Ubuntu). Die beiden kann ich über ihren Hostnamen erreichen. Den ESXi Server aber nicht… Im Pi-Hole Log sehe ich, dass die Anfrage rein kam und auch geforwardet wurde, aber nur ein NXDOMAIN zurückkommt.

Jemand eine Idee, was da schief läuft? Was für Infos werden noch gebraucht? Hab keine Ahnung, wo ich nachschauen muss. Mich wundert es vor allem, dass es bei den meisten klappt, nur ein paar werden nicht gefunden. Es ist auch egal, ob ich esxi2 oder esxi2.fritz.box nehme…

Gruß Tobias


#2

Fur benutzen vom Pi.hole benotigst du eine domain name mit ein TLD.

Esxi2 hat kein TLD, vorbild esxi2.lan

Wenn du nur hostnamen verwenden will dann muss jeder lokalen hosts file die hostname andere machinen enthalten.


#3

Ich hab das bisher noch nie gemacht und es ging ja.
Meine FreeNAS Kiste kann ich auch noch ganz normal mit freenas1 ohne irgendwas erreichen und die UbuntuVM mit dvbserver auch. Das ist ja das, was mich jetzt wundert. Wieso es bei manchen Hostnamen klappt und bei manchen nicht.


#4

Wenn freenas1 im /etc/hosts file enthalten ist dann klappt das.


#5

127.0.0.1 localhost
::1 localhost ip6-localhost ip6-loopback
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters

127.0.1.1 raspberrypi

Das steht in /etc/hosts
Klar, ich könnte da jetzt alle eintragen, aber das wollte ich vermeiden. Und wie gesagt, es ist dieser Mischmasch von geht und geht nicht, der mich stört…


#6

Hostnamen mussen im /etc/hosts stehen

Willst du Pi.hole benutzen dann mussen es namen. Dann noch immer vermelden im /etc/hosts.

Kann auch mit Pi-hole uber dnsmasq.

Im /etc/dnsmasq.d/05-local-domains.conf (neuen file)

host-record=hostname,168.192.0.2

http://www.thekelleys.org.uk/dnsmasq/docs/dnsmasq-man.html


#7

was für eine Pi.hole version hast du ?

ssh Verbindung und frag in mal - pihole -v

in der Neue version ist dnsmasq im FTLDNS integriert

ich muss keine Datei erstellen bei mir läuft alles ohne Probleme.


#8

Pi-hole version is v4.2.1 (Latest: v4.2.1)
AdminLTE version is v4.2 (Latest: v4.2)
FTL version is v4.2.1 (Latest: v4.2.1)

Die Fritzbox übernimmt bei mir DHCP und verteilt Pi-Hole als DNS Server. Conditional Forwarding mit der IP und fritz.box ist eingetragen. In der Fritzbox ist bei DNS Rebound Schutz pi.hole als Ausnahme eingetragen.


#9

ok scheint alles richtig zu sein.

ich würde mal empfehlen die FB und den Pi neu zu starten. mal sehen was er dan macht…


#10

Hab ich vorhin gemacht, hat nicht wirklich geholfen. Hab jetzt für die zwei Server beim Pi in der /etc/hosts zwei Einträge gemacht. Damit gehts vorerst. Wobei da wieder seltsam ist, dass beide Server bisher immer ein NXDOMAIN bei Anfragen zurückbekommen haben, ich aber trotzdem auf deinen einen drauf kam und auf den anderen nicht^^


#11

ok es scheint das Herr matter in deinem fall recht hat.
sehr gut wieder was gelernt … aber wie du bereits sagst ist es komisch ? da davor alles ging.

zeit wan hast du das problem ? seit der ver. update pi


#12

Seit letzter Woche.
Ich glaub, da hab ich irgendwann das 7.01 Update für meine Fritzbox von Vodafone aufgespielt bekommen. Das war auch letzte Woche. Das könnte damit zeitlich schon zusammen passen.
Allerdings hab ich auch da irgendwann Pi-Hole geupdatet…

Ich merke, ich war letzte Woche zu fleissig :stuck_out_tongue:
Aber trotzdem bleibt es komisch, dass es nur bei zwei Hostnamen nicht klappt, aber beim Rest bisher schon?!