PiHole stopped running.

PiHole ran successfully for about 24 Hrs, then stopped. As far as I can see it's fallen back to the router's (FreshTomato) DNS 2 (1.1.1.1). Replacing DNS 2 with 0.0.0.0 stops all traffic and doesn't force the use of DNS 1.
DNS 1 points to the RasberryPi address, on which I'm running PiHole: 191.168.1.38

I've seen suggested in other similar reports, to run on the PiHole machine (Raspberrypi) and the client machine (Linux laptop):

Pihole:
Server: 127.0.0.1
Address: 127.0.0.1#53
Name: flurry.com
Address: 0.0.0.0
Name: flurry.com
Address: ::

Linux Laptop:
Server: 127.0.0.53
Address: 127.0.0.53#53
Non-authoritative answer:
Name: flurry.com
Address: 74.6.136.153
Name: flurry.com
Address: 212.82.100.153
Name: flurry.com
Address: 98.136.103.26

I'd be grateful for a bit of help, as I'm an 'old-newbie'!
Jim

Debug Token: 67axm373yu

There should be no DNS2 that leads to a DNS server other than Pi-hole. With this DNS server available, the clients are free to use it and some of the DNS traffic will bypass Pi-hole.

Your debug log shows that when Pi-hole tested DNS resolution for a known blocked domain, it was unable to reach the Pi on the outward-facing IP. This indicates a connectivity problem with the Pi on that IP on port 53.

*** [ DIAGNOSING ]: Name resolution (IPv4) using a random blocked domain and a known ad-serving domain
[✓] www.mathenea.com is 0.0.0.0 via localhost (127.0.0.1)
[✗] Failed to resolve www.mathenea.com via Pi-hole (192.168.1.38)
Pihole:
Server: 127.0.0.1
Address: 127.0.0.1#53
Name: flurry.com
Address: 0.0.0.0
Name: flurry.com
Address: ::

This output is normal. The DNS query was answered on the loopback address of the Pi, and the outward facing IP was not used.

Run nslookup flurry.com 192.168.1.38 from the Pi terminal and see if the result is the same.

Linux Laptop:
Server: 127.0.0.53
Address: 127.0.0.53#53
Non-authoritative answer:
Name: flurry.com
Address: 74.6.136.153

This DNS query does not appear to have gone to Pi-hole, but to the loopback address on that Linux client. The query went to whatever DNS server you have specified for that client, which is not Pi-hole.

Thanks for the prompt reply.

I have no DNSs set on the Linux network settings. Don't clients make DNS requests to my Freshtomato router and the router then pass it on to PiHole?

DNS1 on the router is set to that of the Raspberrypi (192.168.1.38). If I set DNS2 to 0.0.0.0 it kills the network and I have to manually power cycle the router to get the network back up and then set DNS2 to a valid address (1.1.1.1)

As you may probably have gathered, I'm very unfamiliar to networking and only have the vaguest concepts!

You can try a valid address such an unused IP from your internal LAN range.

"You can try a valid address such an unused IP from your internal LAN range."

Tried it - it killed the WAN.

It seems that the system is determined to ignore the PiHole setup.

It's a pity,because it was working so well for a day. I've gone back to my fall-back position of using the Adblock feature of Freshtomato.

Thanks for the reply.
Jim

Have you checked for rebind protection on the router? And any other DNS settings that would avoid a local resolver (family friendly DNS, etc.).

You also have the option to use Pi-hole as the DHCP server, which should avoid any of these problems.

" Using Your Existing Router For Network-wide Ad Blocking You might not need to use Pi-hole’s DHCP server: In many home environments, your router also functions as your DHCP server. In this case, you can often set Pi-hole to be the DNS server for your network clients in the router’s DHCP (or LAN) settings page, which allows all of your network clients to block ads simply by connecting to the network. Setting it up this way is also what makes Pi-hole very powerful for network-wide ad blocking. W…"

I appreciate the above and it's what I aimed for on my router - DNS1 points to the PiHole LAN address..

I'm going to reconfigure PiHole (<pihole -r>) and see it it helps.

I'm getting pretty discouraged and if reconfiguring doesn't work I'm ditching PiHole and going back to using the built-in Adblock on my router. It's a shame because I like the principle of PiHole on a Raspberrypi and also the handy web monitoring page.

Thanks agin for the support.
Jim

OK - given up on this one!

I was hoping that someone would come along with the same set-up as me (PiHole on Rasberry pi, Freshtomato router), but it's not happened.

I've gone back to the perfectly adequate Adblock on the router (but I did like the idea of doing it on a Pi - especially with the nice web interface).

Thanks for the help from everyone.
Jim

That 191.168.1.38 IP address is outside the private IPv4 address range:

Whats your router IP ?
Shouldnt it be 192.168.1.38 ?
Typo somewhere ?

Try enter the Pi-hole address for DNS1 & DNS2.