PiHole statistics show it working, but it doesn't block basic ads


#1

Please follow the below template, it will help us to help you!

Going on this page shows both google and amazon ads. However, when I go into the admin I can see the PiHole blocking some things. Any idea what’s going on here?

Latest pihole, brand new PiZeroW, fresh Raspbian Lite Stretch, basic pihole config (no additions or subtractions from pi list.)

Expected Behaviour:

Pihole blocks ads.

Actual Behaviour:

Pihole doesn’t block ads.

Debug Token:

95sbrqpui7


#2

I only see entries for localhost. Have you configured your devices to use Pi-hole as their DNS server? Otherwise, everything else seems to be in order.


#3

There are no DNS server settings on my router. Does this mean I have to edit the DNS manually on all the devices?


#4

Did you look under DHCP options. This is another place it commonly is.

Even if your router can’t, Pi-hole can serve as your DHCP server, so you don’t need to manually configure all your devices.


#5

There are no manual DHCP options in my router. I’ve already followed the instructions you provided to disable DHCP on my router and enable it on the pihole. That’s working and I have an internet connection again, I’m just not blocking any ads on the devices connected to the pihole.


#6

OK, can you send another debug token now that you have made those changes?


#7

I made those changes yesterday, but I’ll create a new token anyway.

fd1rxfo3em


#8

From one of your devices, can you

dig a-ads.com @192.168.1.182

#9

Sure.

; <<>> DiG 9.10.3-P4-Ubuntu <<>> a-ads.com @192.168.1.182
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 10073
;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 4096
;; QUESTION SECTION:
;a-ads.com.			IN	A

;; ANSWER SECTION:
a-ads.com.		2	IN	A	192.168.1.182

;; Query time: 7 msec
;; SERVER: 192.168.1.182#53(192.168.1.182)
;; WHEN: Sun Mar 25 14:54:39 EDT 2018
;; MSG SIZE  rcvd: 54

#10

Bumpity. Are we allowed to do that here?


#11

According to that command, your Pi-hole is working because it is returning your local IP instead of the real IP of a-ads.com.

Can you manually set your devices to use Pi-hole as their DNS server?


#12

Honestly, I’m a bit disappointed that this is the only option. I was really hoping to be able to achieve ad blocking on my smart TV and my streaming dongles (we have a chromecast and an Amazon Fire stick.) Since I can’t set the DNS on those devices they’ll never be able to receive the benefits of pihole. Also, my guests can’t take advantage of it, either, without somehow configuring their DNS settings as well. In addition, it looks like the only way I can change DNS on my android device without root is to install a third party closed-source application. Unfortunately, my internet provider does not allow the use of third party routers, so that option is out as well.

This means I’m left with a half-baked solution that needs a bunch of manual workarounds and third party hacks to even work at all.

The last day or so was a bit frustrating and frankly speaking I think your front page is slightly deceiving. There should be a big red warning that says “make sure your router has the following feature(s) before downloading” or something (manual DHCP entry, dnsmasq settings, etc.). I know that’s probably horrible marketing, but the alternative is someone who went through a day and a half of troubleshooting only to find out his pihole is seriously gimped. The package installation, web interface and debugging process was a joy to work with, but the unstated hardware requirements and scattered documentation was far from ideal.

Hopefully this feedback is helpful in some way. Thanks for all of your help.


#13

We haven’t finished debugging yet. If you’re using Pi-hole’s DHCP server, you should make sure your router’s DHCP is disabled. You should also restart your network devices so they pick up the new lease and DNS settings.

Several Google devices hardcode their own DNS servers, so that’s a limitation Pi-hole has no control over.

I’m sorry you feel that way, but like I said, we haven’t finished troubleshooting yet. Why don’t you post some screenshots of your router’s DHCP settings page and LAN settings page as a next step.

You can still use Pi-hole on devices that can have their DNS servers manually configured, but yes I understand your frustration on those devices that cannot.

We do link directly to our hardware/software requirements from the main page, but you’re right, we don’t mention anything about the router. I will fix that tonight.


#14

Edits to the HW/SW requirements have been completed.


#15

Sorry I did not get back sooner, but I’d like to give this a go. If I can get it working on some devices it is better than none. I’m also looking into getting my own router and just setting it up behind the AT&T one, giving me much more control.

DHCP is enabled on the pihole and leasing out connections. However, when I enter the pihole’s IP as the DNS on my devices, I still get ads.

The odd thing is I’m showing that ads are being blocked, but when I go here I can see the ads.

When I checked back after posting this, the pi-hole began blocking them! However, on my tablet they still appear.

Debug token: 4vn2cq4p5s


#16

You’re probably dealing with cache. Try clearing it on your tablet or other devices.


#17

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.