Pihole only working on local host


#1

Hello I’ve installed pihole on a spare laptop on my network running ubuntu server.
I am using Google DNS on my main router.

It seems that pihole doesn’t work on any devices on my network other than the laptop itself.

I’ve tailed the /var/log/pihole.log while running w3m in a second terminal and the only time entries to the logs are made is when I am hitting a website using that local machine using the w3m browser via secondary terminal.

Debug Token: 1ui5kznx4m


—= Detecting Installed Package Versions:
::: Pi-hole: v3.0.1 (master:v3.0.1-0-g26fcb1b)
::: Pi-hole Dashboard: v3.0.1 (master:v3.0.1-0-ge204cea)
::: lighttpd/1.4.35
::: PHP 7.0.18-0ubuntu0.16.04.1 (cli) ( NTS )
:::
::: —= Detecting existence of /etc/pihole/setupVars.conf:
::: File exists, parsing…done and was successfully sourced
:::
::: —= Detecting installed OS Distribution
:::
::: —= Checking processor variety
:::
::: —= Checking IPv6 Stack
::: IPv6 addresses located on enp0s25
::: No gateway detected.
:::
::: —= Checking IPv4 Stack
::: IPv4 addresses located on enp0s25
::: Pinging default IPv4 gateway: Gateway responded.
::: Pinging Internet via IPv4: Query responded.
:::
::: —= Daemon Process Information
::: Checking http port for lighttpd listener.
::: Correctly configured.
:::
::: —= Daemon Process Information
::: Checking domain port for dnsmasq listener.
::: Correctly configured.
:::
::: —= Daemon Process Information
::: Checking 4711 port for pihole-FTL listener.
::: Correctly configured.
:::
::: —= Processes Check
::: Logging status of lighttpd, dnsmasq and pihole-FTL…
:::
::: —= Resolver Functions Check (IPv4)
::: Checking for necessary lighttpd files.
:::
::: —= Detecting existence of /etc/lighttpd/lighttpd.conf:
::: File exists, parsing…done
:::
::: —= Detecting existence of /var/log/lighttpd/error.log:
::: File exists, parsing…done
:::
:::
::: —= Detecting existence of /etc/dnsmasq.conf:
::: File exists, parsing…done
:::
::: —= Detecting contents of /etc/dnsmasq.d/*:
:::
::: —= File /etc/dnsmasq.d/01-pihole.conf found
::: Parsing…done
:::
::: —= File /etc/dnsmasq.d/README found
::: Parsing…done
:::
:::
::: —= Detecting existence of /etc/pihole/whitelist.txt:
::: File exists, parsing…done
:::
::: —= Detecting existence of /etc/pihole/blacklist.txt:
::: /etc/pihole/blacklist.txt not found!
:::
::: —= Detecting existence of /etc/pihole/adlists.list:
::: File exists, parsing…done
:::
::: —= Analyzing gravity.list
:::
::: —= Analyzing pihole.log
:::
::: —= Analyzing pihole-FTL.log
:::
::: --= User Action Required =–
::: Try loading a site that you are having trouble with now from a client web browser…
::: (Press CTRL+C to finish logging.)
Pastebin of my Debug Log: https://pastebin.com/r0p0YsWS


#2

From another device on your network, can you please run these commands to test Pi-hole’s functionality?

dig doubleclick.com @192.168.11.14
dig google.com @192.168.11.14
curl -I 192.168.11.14
curl -I pi.hole/admin/

#3

ran the following on my iMac
dig doubleclick.com @192.168.11.14
; <<>> DiG 9.8.3-P1 <<>> doubleclick.com @192.168.11.14
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 2597
;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;doubleclick.com. IN A

;; ANSWER SECTION:
doubleclick.com. 300 IN A 192.168.11.14

;; Query time: 6 msec
;; SERVER: 192.168.11.14#53(192.168.11.14)
;; WHEN: Tue Jun 13 09:19:34 2017
;; MSG SIZE rcvd: 49
dig google.com @192.168.11.14

; <<>> DiG 9.8.3-P1 <<>> google.com @192.168.11.14
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 13497
;; flags: qr rd ra; QUERY: 1, ANSWER: 6, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;google.com. IN A

;; ANSWER SECTION:
google.com. 299 IN A 74.125.138.101
google.com. 299 IN A 74.125.138.113
google.com. 299 IN A 74.125.138.139
google.com. 299 IN A 74.125.138.138
google.com. 299 IN A 74.125.138.100
google.com. 299 IN A 74.125.138.102

;; Query time: 35 msec
;; SERVER: 192.168.11.14#53(192.168.11.14)
;; WHEN: Tue Jun 13 09:20:31 2017
;; MSG SIZE rcvd: 124

curl -I 192.168.11.14
HTTP/1.1 404 Not Found
X-Pi-hole: A black hole for Internet advertisements.
Content-type: text/html; charset=UTF-8
Date: Tue, 13 Jun 2017 13:21:00 GMT
Server: lighttpd/1.4.35

curl -I pi.hole/admin/
curl: (6) Could not resolve host: pi.hole


#4

Perhaps a stupid question…
Did you set your dns to the pihole on the “other” devices?
If your router is set to google, it will also probably send that google dns to your clients.
So pihole is not used.
Have your main router’s dhcp hand out 192.168.11.14( your pihole ???) as dns.
Also disable dns from ip6 dhcp on the router if needed.


#5

the pihole upstream dns is set to google (ipv4) and my router is set to R7000 Netgear is set to googles 8.8.8.8 and 8.8.4.4 as its dns


#6

Exactly.
If you do not tell your clients to use pihole as DNS, nothing will be blocked.

do ipconfig /all on a (windows) client (so not the machine with pihole!)
what is the dns?
It should not be 8.8.8.8 or 8.8.4.4 or 192.168.11.1 (your router?) but 192.168.11.14


#7

ah, should I then make my routers Gateway (192.168.11.1) DNS to the pihole (192.168.11.14) this way I dont have to manually do it on each of my devices I did an ipconfig all on one of my windows laptops and it looks like the DNS is showing up as my router (192.168.11.1)


#8

No, or sometimes yes.

Gateway is the route to the outside world, dont change that.
In dhcp setting in your router change the dns server to clients to 192.168.11.14

Not all routers work the same. Some routers only send out DNS as their own adress . In your case: 192.168.11.1
Inside the router this request is translated to the dns listed on the wan side.
Try to see if you can find a setting in dhcp that allows you to change dns.
Sometimes you have to find a setting that looks like this:
Specify a specific dns …or similair.
Did some digging for you:
http://documentation.netgear.com/dg834n/enu/202-10197-02/Advanced.7.3.html
It states:
“Primary DNS server, if you entered a primary DNS address in the Basic Settings screen; otherwise, the router’s LAN IP address” exactly as you discribe it.

So find the spot where you told 8.8.8.8 and 8.8.4.4 are the dns server (in basic settings) and change the primairy DNS to 192.168.11.14

I think it is here: BASIC Home=> internet. =>Use These DNS Servers
Reboot a client and check dns again.

Try to see if you can change the DNS 192.168.11.14
As a last resourt, you could disable the dhcp lan function and setup dhcp server on your ubuntu server.
Think the latest pihole can even do this for you on the gui.


#9

this tells me your device is not configured to use Pi-hole since it doesn’t know the pi.hole domain, which is known when you clients are using Pi-hole.

@Jeroen1 has it right. You can either set each device manually to use Pi-hole as their DNS server, or set it on your router’s config page (under LAN or DHCP options).

We have an FAQ on this to help you:


#10

Thank you guys.

I got it to work.

I set my routers Primary DNS and Secondary to the pihole IP’s

It seems to be working on every device after restarting the router and the pihole host.


#11

Nice to see you got it sorted.

Tip:
As a backup you could try changing the router secondairy dns to 8.8.8.8.
Why?..
If your pihole dies for some reason, your clients will/may fall back to google dns. (happy wife and kids)
This is not 100% failsafe. Sometimes clients have a diffrent behaviour when a second dns is provided.
Or your router may threat the 2 dns servers as 1 and do lookups on both. In that case you get weird responses.
You need to test this in your environment. Do a ping to a blocked domain. If the answer is not always192.168.11.14, set both dns servers back to pihole like you have done today.