Pihole not working after docker install on Synology DSM 7.1

I have access to PIHOLE ( Pihole is not seeing any traffic and I dont know why.

DSM 7.1.1Router Synology RT2600acDocker

Followed this youtube tutorial that included these steps:

1.Set up shared folder and subfolders in Docker folder:-pihole /pihole /dnsmasq.d

  1. Downloaded and installed Pihole image

  2. Launched Image and applied env. variables as follows:

  • Container name: pihole
  • Webpassword
  • Port: 8888
  • ServerIP: (Same as NAS) - Mapped the volumes to the mounting paths of previous created folders
  1. Created a DNS record bingo.home.lan with IP and secondary to

  2. Changed my Primary DNS on my router to the synology NAS

my debug token

Though your debug log shows Pi-hole to be operational, I'm not sure if I would trust that tutorial (or maybe you've been mistyping?):
Port is not a name of any Pi-hole environment variable, ServerIP has long been deprecated in favour of FTLCONF_LOCAL_IPV4, Pi-hole's UI wouldn't allow to create two A records (2 IPv4) for the same hostname bingo.home.lan, and I don't understand the significance of pointing bingo.home.lan to both a private ( and a public ( range IPv4 address.

Finally, your issue seems to be related to item 5, which would configure your router to distribute its own IP ( as local DNS server.
This is indeed confirmed by your debug log:

*** [ DIAGNOSING ]: Discovering active DHCP servers (takes 10 seconds)
   Scanning all your interfaces for DHCP servers
   * Received 307 bytes from eth0:
     Offered IP address:
     DHCP options:
      Message type: DHCPOFFER (2)
      --- end of options ---

In such a configuration, your clients would always be able to by-pass Pi-hole via, and such a by-pass would also happen via your router's, unless you'd configured your router to use Pi-hole as its upstream DNS server.
As you are not observing any DNS traffic in Pi-hole's Query Log, I assume that is not the case, and none of your clients is using Pi-hole for DNS.

Pi-hole has to be the sole DNS server for your network, see also Post-Install - Pi-hole documentation.

You should change your router's configuration to distribute only your Pi-hole host's IP (which your debug log suggests to be as local DNS server via DHCP.

You should probably also take a look at Pi-hole's Docker documentation.
While that documentation is geared towards plain Docker, I'd still recommend that you try to match that against your current Synology Docker configuration.

Thank you, I deleted the secondary DNS of and all of my environmental variables were indeed initially set as you instructed. Sorry about misreading/typing the names incorrectly.
After changing the primary dns to be, I am obviously not understanding something. All of my devices are still not connecting through the Pihole server. Here is my my synology 2600ac router setup.

Clients will start to pick up those altered DNS settings only after renewing their DHCP lease.
You may force that by dis- and reconnecting a device to your network, or by power-cycling a device or your router.

thanks. thats what i did. works now. pretty incompetent with networking. Im trying.