Pihole not directing clients to PXE Server


#1

I am using Pihole for DNS and DHCP on my home network on a R-PI. I have a PXE server on another device (10.0.0.239) and wanting clients to boot to it when pressing F12.

I have configured a new file in /etc/dnsmasq.d as follows:

root@raspberrypi:/etc/dnsmasq.d# cat 10-tftp.conf
dhcp-option=66,“10.0.0.239”
dhcp-boot=pxelinux.0,10.0.0.239

tftp is configured and confirmed to be working on 10.0.0.239
pxelinux.0 file is in the root of tftp directory

I have done a ‘tcpdump port 69’ on te PXE server while trying to PXE boot a client and there are no connections.

The client simply gives a pxe-e32 tftp open timeout as below:

At a total loss as to why this isn’t working.

Is any other dnsmasq configuration required on pihole? Or, do I need to configure dnsmasq on the PXE server?

Also, I want to confirm the /etc/dnsmasq.d directory is still used since FLTDNS is used.


#2

In the dnsmasq manual I read about a dhcp-broadcast option.


#3

Since this is a dnsmasq problem, not Pi-hole, have you tried contacting the dnsmasq mailing list? http://lists.thekelleys.org.uk/mailman/listinfo/dnsmasq-discuss

FTLDNS just contains an embedded dnsmasq, which operates just like normal dnsmasq.


#4

Ok, I’ve managed to find the solution. I was originally using the answer provided in this post:

Which said to use this config file:
root@raspberrypi:/etc/dnsmasq.d# cat 10-tftp.conf
dhcp-option=66,“10.0.0.239”
dhcp-boot=pxelinux.0,10.0.0.239

However it obviously was not working.

Solution:

root@raspberrypi:/etc/dnsmasq.d# cat 10-tftp.conf
dhcp-boot=pxelinux.0,10.0.0.239

10.0.0.239 is the PXE server.

For some reason, the double comma is not coming through on the post. Should be 2 commas between the 0 and 10, screen shot below.

Issue resolved, thanks.


#5

Double comma, write \,\,


#6

i’ll try to correct my post and see that really my post have double “,” but it’s not show, sorry for this.

Sometimes it’s better a screen capture like you do.

Thanks for the aclaration.


#7

You could also use the code button </> for this

Abc,,def


#8

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.