Pihole not blocking

Expected Behaviour:

block and log sites i visit

Actual Behaviour:

doesn't block any site whatsoever

Debug Token:

v1Sd8Uoy

now query logs are showing all of a sudden saying google.com was blocked on the jonathan device yet on the device it's not blocked

There is a typo in your token - I assume the correct one to be
https://tricorder.pi-hole.net/vlSd8Uoy/

If that would be yours, your router would be distributing its own IP as DNS server:

*** [ DIAGNOSING ]: Discovering active DHCP servers (takes 10 seconds)
   Scanning all your interfaces for DHCP servers
   
   * Received 331 bytes from enp1s0:192.168.10.1
     BOOTP server: pxeserver
     BOOTP file: bootd\wdsmgfw.efi
     DHCP options:
      Message type: DHCPOFFER (2)
      dns-server: 192.168.10.1
      router: 192.168.10.1
      --- end of options ---

That could still be a valid configuration if your router would use Pi-hole as its sole upstream.

Have a read of Pi-hole's general Post Installation documentation .

yes that would be me, sorry it's tough to get the letters right when you can't copy and paste lol, anyway thanks for this i will try it

i'm 100% confused as to why it's needed this way, doing it this way means i can't check per host. i've setup the exact same in the past and didn't have this happening. any help you can think of?

also when trying i get the same results, it says blocked via pihole query log but still accessible on the device when i put pihole as sole upstream for my router

also i do have my dhcp servers set to pihole for dns, and i've tried statically assigning ip and dns to devices and still nothing just that one subnet doesn't have it's dhcp server set to pihole

i have the most basic of a setup. ubuntu 20 static ip set with it's dns set to 1.1.1.1,1.0.0.1, installed pihole via curl command, then statically set pihole as dns for my device and tried. something is not at all clear for me that it would log blocked yet i can go to it on device, what instance could this be correct?

I didn't put out any requirements.

Could you explain what it is that you think would be needed, and why?

seems i had everything 100% correct, stupid private dns on android devices was the cause, thanks :slight_smile: