Pihole log not working - Query log fine


#1

Hi all,

I recently upgraded Pi-hole to v4.2.1.

Expected Behaviour:

From GUI: Tail pihole.log should display pihole entries. From CLI: pihole -t should show entries.

Actual Behaviour:

Nothing is being logged to pihole.log. Viewing both from the GUI and SSH (pihole -t / tail /var/log/pihole.log). Log shows entries from before the upgrade.

Debug Token:

Use netcat.

I’ve never tried the debug before… Not sure why this isn’t working… I also tried pihole -r which didn’t work.

Please let me know if anyone has any suggestions.


#2

You ran a debug log and it would not generate a log, or it generated a log and would not upload the log?

What is the output of these commands from the terminal:

cat /etc/pihole/pihole-FTL.conf

sudo grep QUERY /etc/pihole/setupVars.conf


#3

I generated the debug log but it would not upload.

For some reason /var/log/pihole.log randomly started working again just now… And this was even after pihole -r followed by a reboot. The previous entries in the pihole log are all from before the upgrade two days ago.

Maybe Pi-hole knew I was posting here so it decided to start working again. ¯_(ツ)_/¯

Output below:

root@Pi-Server:~# cat /etc/pihole/pihole-FTL.conf
PRIVACYLEVEL=0

root@Pi-Server:~# sudo grep QUERY /etc/pihole/setupVars.conf
API_QUERY_LOG_SHOW=blockedonly
QUERY_LOGGING=true


#4

This generally indicates that there is a problem with domain name resolution. Please generate a log and upload it to verify that you can. Post the token and we’ll peek under the hood.


#5

Much appreciated! - Whatever issue was impacting the Pi I believe has now been resolved. The debug token / upload mechanism is now working as well:



[✓] Your debug token is: qjzqmhq00s




#6

The debug log is normal. Good that it’s working again for you.